Author Topic: Strange error when running my program  (Read 212 times)

Offline igdegoo

  • Single posting newcomer
  • *
  • Posts: 3
Strange error when running my program
« on: December 28, 2017, 05:53:08 pm »

I have no idea why this pops up.
When I run in the Code::Blocks editor it runs fine, but when I run the .EXE from the file explorer I get that message.
I am using MinGW compiler.

I can post the source code if it is required.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10474
    • Travis build status
Re: Strange error when running my program
« Reply #1 on: December 28, 2017, 06:20:04 pm »
It is either a missing dll or mismatched dll. Use dependency walker to find which of the two is...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline igdegoo

  • Single posting newcomer
  • *
  • Posts: 3
Re: Strange error when running my program
« Reply #2 on: December 28, 2017, 06:41:06 pm »
It is either a missing dll or mismatched dll. Use dependency walker to find which of the two is...
What is dependency walker?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10474
    • Travis build status
Re: Strange error when running my program
« Reply #3 on: December 28, 2017, 07:15:25 pm »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline igdegoo

  • Single posting newcomer
  • *
  • Posts: 3
Re: Strange error when running my program
« Reply #4 on: December 29, 2017, 04:21:15 pm »
http://bfy.tw/Uww
thanks, it works now
do you know how to compile it without it requiring all these DLLs?