Author Topic: How to stop codeblocks from asking me to reload the file?  (Read 575 times)

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 8
How to stop codeblocks from asking me to reload the file?
« on: December 24, 2017, 08:48:51 pm »
I'm on fedora, everytime I press the super key (windows key) codeblocks shows me this



How to stop?  I don't want it to reload anything, I just want it to act normal, like any IDE or text editor

Offline raynebc

  • Almost regular
  • **
  • Posts: 149
Re: How to stop codeblocks from asking me to reload the file?
« Reply #1 on: December 25, 2017, 11:04:16 am »
My favorite text editor asks if I want to reload a file that I edited outside the text editor.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1783
Re: How to stop codeblocks from asking me to reload the file?
« Reply #2 on: December 25, 2017, 11:52:53 am »
Quote
How to stop?  I don't want it to reload anything, I just want it to act normal, like any IDE or text editor

What is the expected behavior? You have modified the file on disk and codeblocks detects it. Are you satisfied if codeblocks overwrites silently your work? I don't think so.

If you don't have modified the file on disk this can be a bug and we need to investigate future...

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 8
Re: How to stop codeblocks from asking me to reload the file?
« Reply #3 on: December 25, 2017, 11:57:17 pm »
I haven't modified anything, nothing nothing, I said everytime I press super key i see this popup, lets say I'm programming, then I press the key to surf a website, or whatever the reason, I come back, I see the popup, on any project everytime, always. I'm fedora 27 64 bit using dnf gnome, I have version 16.01

It's a bug that needs to be fixed, and speaking of bugs, the forum does not send emails notifying me that you replied.

I've been using codeblocks since god knows when, I don't remember writing c++ elsewhere, maybe 2011 or so, probably even before any of you started using it, and you just assume I'm noob because I have low points or something, and jumped to conclusions even though my question was clear.

now I'm trying to configure c++ in vscode until you fix the problem and upload it to fedora's repo. I have no choice, Codeblocks is unusable, everytime I press the super key it shows the popup
« Last Edit: December 26, 2017, 12:20:42 am by elieobeid7 »

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1783
Re: How to stop codeblocks from asking me to reload the file?
« Reply #4 on: December 26, 2017, 02:43:44 am »
Quote
I've been using codeblocks since god knows when, I don't remember writing c++ elsewhere, maybe 2011 or so, probably even before any of you started using it, and you just assume I'm noob because I have low points or something, and jumped to conclusions even though my question was clear.
rude... i use cb at least since 2006 ;) From what should we know that you are not a noob? 90% of the user here are noobs that ask silly questions... And your question was not clear. You said that this message pops up. If i now assume that you are a noob ( and this assumption is 90% of the time true) i tell you that your code was modified outside of cb and this message has its meaning and is not useless or something you should turn of by default...

Quote
I haven't modified anything, nothing nothing
You did not said that anywhere in your first post... Also is it possible that a other program modifies the code (source file) without your knowledge? As far as i know codeblocks checks the date code of the file and if it is different from the currently opened, it will ask you this question.

Quote
It's a bug that needs to be fixed
Yes this is true! Sadly i don't know how to find this bug. I have never encountered this bug. Maybe a dev that uses fedora can reproduce this?

Quote
the forum does not send emails notifying me that you replied.
Strange... i get the emails. Maybe you have to turn the option in
Code: [Select]
Profile->Account settings->Modify Profile->Notifications->Turn notification on when you post or reply to a topic.
Quote
now I'm trying to configure c++ in vscode until you fix the problem and upload it to fedora's repo. I have no choice
good luck!

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 8
Re: How to stop codeblocks from asking me to reload the file?
« Reply #5 on: December 26, 2017, 08:32:23 pm »
Nothing is modifying the file, how to stop that behavior? how to stop codeblocks from checking if the file is modified, please I don't want to use vscode nor eclipse, don't force me to, is it possible to make codeblocks stop checking what happens to the files outside the ide? I'm used to codeblocks

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6158
    • My Best Post
Re: How to stop codeblocks from asking me to reload the file?
« Reply #6 on: December 26, 2017, 08:53:04 pm »
If I recall there might be a place in Editor settings; but, I might be thinking of a different software than CB.

Edit: Found a setting to try

Settings -> Environment
Uncheck: "Check for Externally modified files"

Tim S.
« Last Edit: December 26, 2017, 08:57:16 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 8
Re: How to stop codeblocks from asking me to reload the file?
« Reply #7 on: December 26, 2017, 09:47:58 pm »
perfect! it worked  :D :D :D :D :D :D ;D ;D ;D ;D ;D ;D ;D :D :D :D ;) :) :) :) :) :) thanks a ton!

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7251
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: How to stop codeblocks from asking me to reload the file?
« Reply #8 on: December 27, 2017, 10:27:43 am »
perfect! it worked  :D :D :D :D :D :D ;D ;D ;D ;D ;D ;D ;D :D :D :D ;) :) :) :) :) :) thanks a ton!
That's not a solution, just a workaround.

I just created a new project in the same folder to test it.
I can not reproduce the issue, neither with 16.01 from Fedora repo nor with my nightly.
Does this happen with every project ?
Can you provide steps to reproduce ?