Developer forums (C::B DEVELOPMENT STRICTLY!) > Development

BUG "Execution of ... failed"

(1/1)

ouille:
Hello,

I have an annoying bug.

Discovered in 16.01 but still present in last 17.xx build (binary release).

System : Windows 7pro x64

Working on New installation of CB 16.01 with mingwin directly download from sourceforge.

Tested, and same behavior after updating codeblocks to 17.xx (binary download)

Path in compiler settings are corrects (C:\Program Files (x86)\CodeBlocks\MinGW)

1) Project sample in attachment.

2 )I've search forum for solution but nothing can help to solve this issue.

Here is the details :

Opening project from shell.

First rebuild of project is ok :


--- Quote ----------------- Clean: Debug in tests (compiler: GNU GCC Compiler)---------------

Cleaned "tests - Debug"

-------------- Build: Debug in tests (compiler: GNU GCC Compiler)---------------

mingw32-gcc.exe -Wall -g  -c E:\tmp\tests\main.c -o obj\Debug\main.o
mingw32-g++.exe  -o bin\Debug\tests.exe obj\Debug\main.o   
Output file is bin\Debug\tests.exe with size 28.47 KB
Process terminated with status 0 (0 minute(s), 0 second(s))
0 error(s), 0 warning(s) (0 minute(s), 0 second(s))

--- End quote ---

Second rebuild is ok :

--- Quote ----------------- Clean: Debug in tests (compiler: GNU GCC Compiler)---------------

Cleaned "tests - Debug"

-------------- Build: Debug in tests (compiler: GNU GCC Compiler)---------------

mingw32-gcc.exe -Wall -g  -c E:\tmp\tests\main.c -o obj\Debug\main.o
mingw32-g++.exe  -o bin\Debug\tests.exe obj\Debug\main.o   
Output file is bin\Debug\tests.exe with size 28.47 KB
Process terminated with status 0 (0 minute(s), 0 second(s))
0 error(s), 0 warning(s) (0 minute(s), 0 second(s))

--- End quote ---

But then every new rebuild will fail :

--- Quote ----------------- Clean: Debug in tests (compiler: GNU GCC Compiler)---------------

Cleaned "tests - Debug"

-------------- Build: Debug in tests (compiler: GNU GCC Compiler)---------------

mingw32-gcc.exe -Wall -g  -c E:\tmp\tests\main.c -o obj\Debug\main.o
Execution of 'mingw32-gcc.exe -Wall -g  -c E:\tmp\tests\main.c -o obj\Debug\main.o' in 'E:\tmp\tests' failed.

--- End quote ---

Running same command from command line is ok :

--- Quote ---E:\tmp\tests>"c:\Program Files (x86)\CodeBlocks\MinGW\bin"\mingw32-gcc.exe -Wall -g  -c E:\tmp\tests\main.c -o obj\Debug\main.o

E:\tmp\tests>

--- End quote ---

Same type of problem arise when running application, don't know if it's related.
Opening project from shell.

Using build and run. First execution is ok :

--- Quote ----------------- Build: Debug in tests (compiler: GNU GCC Compiler)---------------

Target is up to date.
Nothing to be done (all items are up-to-date).


-------------- Run: Debug in tests (compiler: GNU GCC Compiler)---------------

Checking for existence: E:\tmp\tests\bin\Debug\tests.exe
Executing: "C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "E:\tmp\tests\bin\Debug\tests.exe"  (in E:\tmp\tests\.)

--- End quote ---

Leaving console with "escape" key.

After 3 or 4 more runs fail forever :


--- Quote ----------------- Build: Debug in tests (compiler: GNU GCC Compiler)---------------

Target is up to date.
Nothing to be done (all items are up-to-date).


-------------- Run: Debug in tests (compiler: GNU GCC Compiler)---------------

Checking for existence: E:\tmp\tests\bin\Debug\tests.exe
Executing: "C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "E:\tmp\tests\bin\Debug\tests.exe"  (in E:\tmp\tests\.)
Execution of '"C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "E:\tmp\tests\bin\Debug\tests.exe" ' in 'E:\tmp\tests' failed.

--- End quote ---

BUT Running command from command line is ok :

--- Quote ---E:\tmp\tests>"C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "E:\tmp\tests\bin\Debug\tests.exe"
Hello world!
Hello world!
Hello world!
...

--- End quote ---

IMPORTANT :
After fail, trying to access settings->compiler then codeblocks crash :

--- Quote ---Signature du problème :
  Nom d’événement de problème:   APPCRASH
  Nom de l’application:   codeblocks.exe
  Version de l’application:   16.1.0.0
  Horodatage de l’application:   00050004
  Nom du module par défaut:   Profiler.dll
  Version du module par défaut:   0.0.0.0
  Horodateur du module par défaut:   00050004
  Code de l’exception:   c0000005
  Décalage de l’exception:   00004335
  Version du système:   6.1.7601.2.1.0.256.48
  Identificateur de paramètres régionaux:   1036
  Information supplémentaire n° 1:   0a9e
  Information supplémentaire n° 2:   0a9e372d3b4ad19135b953a78882e789
  Information supplémentaire n° 3:   0a9e
  Information supplémentaire n° 4:   0a9e372d3b4ad19135b953a78882e789

--- End quote ---

Détail of program.
With a minimal project and minimal C file


--- Code: ---#include <stdio.h>
#include <stdlib.h>

int main()
{
int i;
    for(i=0;i<100;i++)
        printf("Hello world!\n");
    return 0;
}
--- End code ---


BlueHazzard:
this seems more to be a anti virus problem. Can you disable your anti virus and try again?



--- Quote ---Opening project from shell.
--- End quote ---
What do you mean by this? Open codeblocks from command line and then open the project, or open it by double clicking on the workspace file, or by opening the workspace through the command line with parameter?


--- Quote ---IMPORTANT :
After fail, trying to access settings->compiler then codeblocks crash :
--- End quote ---
Is there a codeblocks.rpt (or rtp, or ptr, or xml) file in the installation directory, or temporary directory?

ouille:
Hello,

Bug appear on a domain managed windows system, i use a local account.

So, quitting Kaspersky (windows complain about no antivirus running).

Same problems as before.

Codeblocks crash details :

--- Quote ---Signature du problème :
  Nom d’événement de problème:   APPCRASH
  Nom de l’application:   codeblocks.exe
  Version de l’application:   16.1.0.0
  Horodatage de l’application:   00050004
  Nom du module par défaut:   Profiler.dll
  Version du module par défaut:   0.0.0.0
  Horodateur du module par défaut:   00050004
  Code de l’exception:   c0000005
  Décalage de l’exception:   00004335
  Version du système:   6.1.7601.2.1.0.256.48
  Identificateur de paramètres régionaux:   1036
  Information supplémentaire n° 1:   0a9e
  Information supplémentaire n° 2:   0a9e372d3b4ad19135b953a78882e789
  Information supplémentaire n° 3:   0a9e
  Information supplémentaire n° 4:   0a9e372d3b4ad19135b953a78882e789

--- End quote ---



--- Quote ---Opening project from shell.
--- End quote ---

Double click on project icon, sorry it was not so clear.


--- Quote ---Is there a codeblocks.rpt (or rtp, or ptr, or xml) file in the installation directory, or temporary directory?
--- End quote ---

Not such file on whole disk (searching for codeblocks*.*).

I'll try to test with antivirus disabled. Need to contact an admin.

I thought you're right for antivurus (i don't think about that during my tests), but tests aren't agree.

Have a nice day.


BlueHazzard:

--- Quote ---Codeblocks crash details :
--- End quote ---
sadly this crash details are nearly useless... We need some back trace to know where the application crashed. Normally there should be a crash handler that creates this back trace and stores it in a codeblocks.* file. The reason why this does not work can also be the anti virus, that blocks anything codeblocks does....

Does this crash and problems also happens if your open the workspace through the File->Open?

Navigation

[0] Message Index

Go to full version