Author Topic: Build problem for : NassiShneiderman  (Read 945 times)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Re: Build problem for : NassiShneiderman
« Reply #15 on: November 02, 2017, 09:52:47 pm »
@killerbot: Could you try the attached patch?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5044
Re: Build problem for : NassiShneiderman
« Reply #16 on: November 02, 2017, 10:49:52 pm »
For Windows I would try to avoid that a boost library is needed. Since this will make things to build on windows much more complex.
On linux, it's much easier, people can just install it from the repository.
If indeed that thread security can be disabled, I will also have a look around for that matter.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5044
Re: Build problem for : NassiShneiderman
« Reply #17 on: November 03, 2017, 08:00:51 am »
   BOOST_CPPFLAGS:         -I/usr/include
   BOOST_LDFLAGS:         -L/usr/lib64
   BOOST_SYSTEM_LIB:         -lboost_system

Build succeeded.

Feel free to commit, I would suggest that this gets merged to our RC branch.
« Last Edit: November 03, 2017, 08:05:42 am by killerbot »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Re: Build problem for : NassiShneiderman
« Reply #18 on: November 03, 2017, 08:11:49 am »
Can you try to make a source package and use it to build from it?
The steps are run make dist in your current build folder.
Then unpack the generated package somewhere else and then do ./configure && make && make install (you could probably skip the install).
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5044
Re: Build problem for : NassiShneiderman
« Reply #19 on: November 03, 2017, 03:20:19 pm »
I do this on my patched environment ?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Re: Build problem for : NassiShneiderman
« Reply #20 on: November 03, 2017, 08:42:45 pm »
Yes, use a patched version of the source to generate the tar.gz file and then do not apply the patch.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5044
Re: Build problem for : NassiShneiderman
« Reply #21 on: November 04, 2017, 12:20:04 pm »
Did the experiment : all build well.

And your commit was also nicely accepted by svn up :-)