Author Topic: Help! Code::Blocks 16.01 fails at building  (Read 293 times)

Offline Nonno Umby

  • Single posting newcomer
  • *
  • Posts: 2
Help! Code::Blocks 16.01 fails at building
« on: October 26, 2017, 04:35:27 pm »
Hi everyone!

I recently installed Code::Blocks 16.01, but every time I try to build a project it doesn't work, not even with the default "Hello World" program. When I click on the Build icon, this is what appears in the Build Log:

-------------- Build: Debug in pp (compiler: GNU GCC Compiler)---------------

mingw32-g++.exe  -o bin\Debug\pp.exe obj\Debug\main.o   
Execution of 'mingw32-g++.exe  -o bin\Debug\pp.exe obj\Debug\main.o' in 'C:\Users\user\Desktop\pp' failed.

If I click on the Run icon the message "It seems that this project has not been built yet. Do you want to build it now?" appears. When I click on Yes the same message appears again, and it keeps doing that until I click on the No.


I've tried everything I knew but couldn't resolve this issue. Any help is deeply appreciated.
Thanks in advance.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1540
Re: Help! Code::Blocks 16.01 fails at building
« Reply #1 on: October 26, 2017, 06:30:20 pm »
install a compiler or install the codeblocks version bundled with a compiler

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5969
    • My Best Post
Re: Help! Code::Blocks 16.01 fails at building
« Reply #2 on: October 26, 2017, 08:05:19 pm »
install a compiler or install the codeblocks version bundled with a compiler

Not sure the cause is missing compiler from the first post. Could be that or it might be something else.

http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Nonno Umby

  • Single posting newcomer
  • *
  • Posts: 2
Re: Help! Code::Blocks 16.01 fails at building
« Reply #3 on: November 06, 2017, 07:23:56 pm »
Hi everyone. I was helped by my professor. I don't know the exact details about the problem I had but it had to do with the way I installed the compiler. Now everything works fine, so thanks a lot for your help!