Author Topic: Freeglut on Fedora 26  (Read 189 times)

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 2
Freeglut on Fedora 26
« on: September 30, 2017, 06:08:54 pm »
I have fedora 26, I have latest codeblocks and freeglut and freeglut-devel.

In codeblocks wizard I pick glut project. It asks me to enter a location but it can't detect it. I tried /usr and /usr/include and usr/include/GL. How to get it working?


Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10279
Re: Freeglut on Fedora 26
« Reply #1 on: September 30, 2017, 06:35:22 pm »
You should inspect the wizard script (right click-> edit script) to see what it is trying to achieve.
Probably the wizard is outdated a bit and fails to detect your version of freeglut.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7208
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Freeglut on Fedora 26
« Reply #2 on: September 30, 2017, 07:21:23 pm »
Create a global variable ("Settings -> Global variables") with the name glut and enter "/usr" in base and "/usr/lib64" in lib (without the quotes, of course).
And keep the default $(#glut) as location in the wizard.

Online jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7208
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Freeglut on Fedora 26
« Reply #3 on: September 30, 2017, 07:23:26 pm »
By the way, if you used the wizard the first time, it should have asked you for a variable with name glut (if you do not change the default settings).

Offline elieobeid7

  • Single posting newcomer
  • *
  • Posts: 2
Re: Freeglut on Fedora 26
« Reply #4 on: September 30, 2017, 09:29:30 pm »
This forum isn't notifying me of new replies. Thanks Jens it worked