Author Topic: Build messages tab issue  (Read 212 times)

Offline fast9881

  • Single posting newcomer
  • *
  • Posts: 3
Build messages tab issue
« on: September 23, 2017, 08:04:00 pm »
Hi, i'm having some trouble with the build messages tab as it stays blank no matter what. When i hit the build button C::B launches the compiler, i can perfeclty see the build log tab contents but the messages tab stays blank. I attached a screen just in case. BTW i have C::B 16.01rev10692 wx 3.0.2 64 bit running on lubuntu 17.04.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5943
    • My Best Post
Re: Build messages tab issue
« Reply #1 on: September 23, 2017, 08:10:29 pm »
Post the build log in code tags and maybe someone will see the problem. http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F
The build log is processed by Code::Blocks to create the Build Messages and sometimes new compiler add things that confuse code::blocks.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline fast9881

  • Single posting newcomer
  • *
  • Posts: 3
Re: Build messages tab issue
« Reply #2 on: September 23, 2017, 08:17:59 pm »
Code: [Select]
-------------- Build: Debug in GamaCDNExplorer (compiler: GNU GCC Compiler)---------------

g++ -Wall -fexceptions -g -Iinclude -c /home/bacco/Scrivania/GamaCDNExplorer/src/PageDownloader.cpp -o obj/Debug/src/PageDownloader.o
/home/bacco/Scrivania/GamaCDNExplorer/src/PageDownloader.cpp: In member function ‘void PageDownloader::downloadPage(std::__cxx11::string, std::__cxx11::string)’:
/home/bacco/Scrivania/GamaCDNExplorer/src/PageDownloader.cpp:19:31: error: variable ‘std::ofstream out’ has initializer but incomplete type
     std::ofstream out(filename);
                               ^
Process terminated with status 1 (0 minute(s), 0 second(s))
1 error(s), 0 warning(s) (0 minute(s), 0 second(s))

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1520
Re: Build messages tab issue
« Reply #3 on: September 23, 2017, 08:48:54 pm »
this is probably fixed with commit [r11147]. Before this commit codeblocks had (hard) problems with ubuntu, that looked like your image ...
You should try a newer build of codeblocks.

Offline fast9881

  • Single posting newcomer
  • *
  • Posts: 3
Re: Build messages tab issue
« Reply #4 on: September 24, 2017, 11:11:12 am »
Well, i guess it was a problem with the log i posted. Today i solved thet error and now it works fine

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10279
Re: Build messages tab issue
« Reply #5 on: September 24, 2017, 11:47:00 am »
No, it doesn't it is a random issue, so it will come back until you install fixed version.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]