Author Topic: Missing "Debug" item in the Build target's selection box  (Read 236 times)

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 28
Missing "Debug" item in the Build target's selection box
« on: September 08, 2017, 03:44:00 am »
My toolbar's Build target list box is missing a "Debug" item. How is this added to the list box? Right now there is only one item in the list and that is "Release". Why is "Debug" missing? How is it added?

I am using Codeblocks 16.01, wxWidgets-3.0.3, and WxSmith . It is the first time I have used these, and this problem became apparent when I followed this tutorial:
http://wiki.codeblocks.org/index.php/WxSmith_tutorial:_Hello_world
and I attempted to debug because the built application will not close by means of its own button control, menu item, or windows x icon in the upper right corner. I had to use Build => Abort to close it.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10369
Re: Missing "Debug" item in the Build target's selection box
« Reply #1 on: September 08, 2017, 09:18:42 am »
Try to add a debug target by going to Project -> Properties -> Build targets -> Add.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 28
Re: Missing "Debug" item in the Build target's selection box
« Reply #2 on: September 09, 2017, 12:59:45 am »
It took more than just adding a build target named "Debug" at "Project => Properties => Build targets (tab)". There were additional steps.

Entries had to be made in these fields in the above tab for my Hello_World application:
Quote
Output filename: bin\Release\Hello_World.exe
Objects output dir: obj\Debug\
Every check box in "Build target files:" had to checked, which is most easily done using the "All/? on" button.

In "Project => Build options ...  => Hello_World (tree) => Debug (tree) => Compiler settings (tab)"

These checkboxes had to be checked:
Quote
Debugging => Produce debugging symbols
Warnings => Enable all common compiler warnings (overrides many other settings)

In "Project => Build options ...  => Hello_World (tree) => Debug (tree) => Linker settings (tab):"
Policy and Link libraries fields had to be configured identical to what they are for the Release build target.

In" Project => Build options ...  => Hello_World (tree) => Debug (tree) =>Search directories (tab)" there are three sub tabs named Compiler, Linker, and Resource compiler. All these had to be configured the same as for the Release build target.