Author Topic: Is Boost required to build Code::Blocks  (Read 158 times)

Offline ordak

  • Multiple posting newcomer
  • *
  • Posts: 37
Is Boost required to build Code::Blocks
« on: September 03, 2017, 03:09:03 pm »
Hi,

I am trying to build Code::Blocks revision 11156, I got errors about some packages and I installed them. Last time after 12 minutes of activity, I got this error:

Code: [Select]
ser.lo CParser.cpp &&\
mv -f $depbase.Tpo $depbase.Plo
libtool: compile:  g++ -std=c++11 -DHAVE_CONFIG_H -I. -I../../../../src/include -I/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread -I../../../../src/include -I../../../../src/sdk/wxscintilla/include -I/include/boost-0 -DBOOST_SYSTEM_NO_DEPRECATED -DCB_AUTOCONF -DCB_PRECOMP -DPIC -I../../../../src/include/tinyxml -DTIXML_USE_STL=YES -O2 -ffast-math -Winvalid-pch -fPIC -fexceptions -MT CParser.lo -MD -MP -MF .deps/CParser.Tpo -c CParser.cpp  -fPIC -DPIC -o .libs/CParser.o
CParser.cpp:5:44: fatal error: boost/spirit/include/classic.hpp: No such file or directory


If Boost package was needed, why the error did not show up immediately ?

OS: Ubuntu 16.04.3
PC: ASUS Laptop

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1470
Re: Is Boost required to build Code::Blocks
« Reply #1 on: September 03, 2017, 03:37:18 pm »
Some plugins require boost, gamin and hunspell. The later are for the spellchecker. I don't know what plugin requires boost... To solve this install libboost-all-dev or exclude the plugin from build process...

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7200
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Is Boost required to build Code::Blocks
« Reply #2 on: September 03, 2017, 03:54:21 pm »
The NassiShneiderman-plugin is thge only one that requires boost.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7200
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Is Boost required to build Code::Blocks
« Reply #3 on: September 03, 2017, 03:56:12 pm »
Run "./configure --help" to see how to exclude (or include) plugins.

Offline ordak

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: Is Boost required to build Code::Blocks
« Reply #4 on: September 03, 2017, 06:32:18 pm »
Some plugins require boost, gamin and hunspell. The later are for the spellchecker. I don't know what plugin requires boost... To solve this install libboost-all-dev or exclude the plugin from build process...

You may make a sticky post about package dependency of Code::Blocks and it's Plug-ins.