Author Topic: MinGW/Code::Blocks compile problem.  (Read 8313 times)

Offline kiril_k

  • Multiple posting newcomer
  • *
  • Posts: 12
MinGW/Code::Blocks compile problem.
« on: February 01, 2006, 10:50:05 am »
Hi to ALL.
I'm a new one in WX+MinGW+Code::Blocks programming.
I have installed:
1) C:\MinGW v.3.1.0-1
2) c:\wxWidgets-2.6.2
comiled with:
Code: [Select]
mingw32-make -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=0 clean
mingw32-make -f makefile.gcc USE_XRC=1 SHARED=1 MONOLITHIC=1 BUILD=release UNICODE=0
I have wxmsw26_gcc_custom.dll in the C:\wxWidgets-2.6.2\lib\gcc_dll\
3) I have installed Code::Blocks (codeblocks-1.0rc2) without compiller.
Code::Blocks is set to use MinGW compiller.

I create new wxWidgets Application project. (Project options: using wxWidgets DLL)
When I click build I receive:

-------------- Build: default in myproject1 ---------------
Precompiling header: wx_pch.h
mingw32-g++.exe: compilation of header file requested
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

And doesn't happen anything.

What is my problem?

Thanks in advince.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: MinGW/Code::Blocks compile problem.
« Reply #1 on: February 01, 2006, 11:28:00 am »
Some suggestions that (I hope could help :)):

1) Try with MinGW 5 (or a newer version if any).
2) Try the latest nightly build (IMHO better than RC2).
3) Compile wxWidgets with UNICODE=1 (RC2 is ANSI, but nightly build is UNICODE).

Then it should work.

Michael

PS.: You can always check if you have set all correctly with RC2 (pathes, libraries, included files, etc.).

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: MinGW/Code::Blocks compile problem.
« Reply #2 on: February 01, 2006, 12:09:16 pm »
Precompiling header: wx_pch.h
mingw32-g++.exe: compilation of header file requested
You use gcc 3.2 (or even older).
Use a recent compiler (3.4+) or turn off precompilation (uncheck the "compile" checkbox in the header's properties).
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline troels

  • Multiple posting newcomer
  • *
  • Posts: 71
Re: MinGW/Code::Blocks compile problem.
« Reply #3 on: February 01, 2006, 12:12:27 pm »
I'm also stuck with this 'nothing happens' problem.

http://groups.google.com/group/comp.soft-sys.wxwindows/browse_frm/thread/fa86ca6ea08fa990

I'm using gcc 3.4.4, haven't tried with MinGW 5 yet.

Regards
Troels

Offline kiril_k

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: MinGW/Code::Blocks compile problem.
« Reply #4 on: February 02, 2006, 10:39:11 am »
Thanks to ALL.
I had old version of g++ compiler.
I have solved the problem.
Here is my solution:
1) Installed Code::Blocks with MinGW
2) compiled wxWigdets dll using Code::Blocks' MinGW

For now all work fine.