Author Topic: configure libraries of wxwidget  (Read 183 times)

Offline sebarubiolo

  • Single posting newcomer
  • *
  • Posts: 3
configure libraries of wxwidget
« on: August 27, 2017, 08:56:06 pm »
Hi.
I cant configure the libraries of wxwidgets.
when build i have an error: 'fatal error: wx/wxprec.h: No existe el fichero o el directorio'
the files are in /usr/include/wx-3.0/wx/ , but I do not know how to modify the directory.
Please help me.... that i have to do?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5896
    • My Best Post
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline sebarubiolo

  • Single posting newcomer
  • *
  • Posts: 3
Re: configure libraries of wxwidget
« Reply #2 on: August 28, 2017, 03:06:36 am »
hi stahta01! Thank for answered.
My codeblocks version is 16.01 installed from Synaptic of Debian Strech.
after i installed the program, i install wxwidgets also from Synaptic.

I try run a empty project wx3.0 but the build log throw an error:

Code: [Select]

-------------- Build: Debug in prueba4 (compiler: GNU GCC Compiler)---------------

g++ -Wall -g  -c /home/sebarubiolo/Documentos/programacion/pruebas/wx/prueba4/GUIFrame.cpp -o obj/Debug/GUIFrame.o
/home/sebarubiolo/Documentos/programacion/pruebas/wx/prueba4/GUIFrame.cpp:8:23: fatal error: wx/wxprec.h: No existe el fichero o el directorio
 #include "wx/wxprec.h"
                       ^
compilation terminated.
Process terminated with status 1 (0 minute(s), 0 second(s))
1 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 

i searched the library and exist in 'usr/include/wx-3.0/wx', but the codeblock not recognize.

Which one is my error?


edit: the compiler is:

Code: [Select]

g++ (Debian 6.3.0-18) 6.3.0 20170516
Copyright (C) 2016 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

« Last Edit: August 28, 2017, 03:08:52 am by sebarubiolo »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5896
    • My Best Post
Re: configure libraries of wxwidget
« Reply #3 on: August 28, 2017, 04:09:14 am »
What is the output of the below command on the command line?

Code: [Select]
wx-config --list

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10186
Re: configure libraries of wxwidget
« Reply #4 on: August 28, 2017, 09:05:32 am »
sebarubiolo: You need to install the dev or devel package for wxgtk.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline sebarubiolo

  • Single posting newcomer
  • *
  • Posts: 3
Re: configure libraries of wxwidget
« Reply #5 on: August 29, 2017, 12:26:21 am »
i wrote in terminal wx-config and i realized that i dont have this command. (thansk Tim)
So, installed twxgtk (thanks oBFusCATed) and everything is working.

Gracias Amigos!!!!!!