Author Topic: mismatch between library and program  (Read 384 times)

Offline rbksouls

  • Multiple posting newcomer
  • *
  • Posts: 12
mismatch between library and program
« on: July 06, 2017, 01:31:01 pm »
Hi everyone, here i am one more time, well this time i bring you an usually problem, i tried to install codeblocks in my laptop but when i try to open it it says that there's a mismatch between the library 3.0 and the program 3.0
Both have the same specifications but the c++ ABI from the library is 1010 and the program one is 1009, i think that's the main reason of this problem but i don't know how to fix it , if someone could help me please...
(i've used this program before in this laptop and it worked fine)

Online stahta01

  • Lives here!
  • ****
  • Posts: 5974
    • My Best Post
Re: mismatch between library and program
« Reply #1 on: July 06, 2017, 04:21:37 pm »
You either got an bad CB Installer or you installed it wrong.

The message means the library and program was compiled by different compiler versions or with different compiler options.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline rbksouls

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: mismatch between library and program
« Reply #2 on: July 06, 2017, 07:43:10 pm »
well i forgot to tell you i'm using ubuntu mate and i used the package installer, "sudo apt-get install codeblocks"
« Last Edit: July 06, 2017, 07:45:26 pm by rbksouls »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10371
Re: mismatch between library and program
« Reply #3 on: July 06, 2017, 08:27:27 pm »
And the real problem is? I'm asking, because I've seen people have this message and being able to run codeblocks.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline rbksouls

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: mismatch between library and program
« Reply #4 on: July 06, 2017, 09:53:54 pm »
when i try to run codeblocks from the console it shows me that message and it just open and close itself if i run the .exe so i can't use it.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10371
Re: mismatch between library and program
« Reply #5 on: July 06, 2017, 11:49:29 pm »
Can we see a log?
The missmatch is something that ubuntu/mate developers need to fix, if all packages related to codeblocks are coming from their repos.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]