Author Topic: Menubar does not appear after building  (Read 189 times)

Offline DorMiX

  • Single posting newcomer
  • *
  • Posts: 2
Menubar does not appear after building
« on: June 02, 2017, 01:03:40 pm »
Hi,
I have recently changed to Ubuntu 16.04 32bit from Win7 32bit.
In Win7 I used CB16.01 with wxWidgetsBinary3.0.2. This was working good.
In Ubuntu I am using CB16.01 from here https://launchpad.net/~damien-moore/+archive/ubuntu/codeblocks-stable with wx from here http://codelite.org/LiteEditor/WxWidgets30Binaries
After building (without errors and warnings) first projekt, the MenuBar did not appear on my app. It was a simple Hello World app.

Code: [Select]
-------------- Build: Debug in wx30 (compiler: GNU GCC Compiler)---------------

g++ -I/usr/lib/i386-linux-gnu/wx/include/gtk2-unicode-3.0-unofficial -I/usr/include/wx-3.0-unofficial -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread -Wall -g -std=c++11  -c /home/dormanyr/Programming/wxWidgets/wx30/wx30App.cpp -o obj/Debug/wx30App.o
g++ -I/usr/lib/i386-linux-gnu/wx/include/gtk2-unicode-3.0-unofficial -I/usr/include/wx-3.0-unofficial -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread -Wall -g -std=c++11  -c /home/dormanyr/Programming/wxWidgets/wx30/wx30Main.cpp -o obj/Debug/wx30Main.o
g++  -o bin/Debug/wx30 obj/Debug/wx30App.o obj/Debug/wx30Main.o  -L/usr/lib/i386-linux-gnu -pthread   -lwx_gtk2u_unofficial_xrc-3.0 -lwx_gtk2u_unofficial_webview-3.0 -lwx_gtk2u_unofficial_html-3.0 -lwx_gtk2u_unofficial_qa-3.0 -lwx_gtk2u_unofficial_adv-3.0 -lwx_gtk2u_unofficial_core-3.0 -lwx_baseu_unofficial_xml-3.0 -lwx_baseu_unofficial_net-3.0 -lwx_baseu_unofficial-3.0   
Output file is bin/Debug/wx30 with size 549,20 KB
Process terminated with status 0 (0 minute(s), 7 second(s))
0 error(s), 0 warning(s) (0 minute(s), 7 second(s))

What is the problem here? In Win7 this was working properly! :(

I trried to create more complex app, and build it, but Menubar did not appear...  :(

How can I solve this problem?
I attached my HelloWorld app building log and running app picture!
Thanks for your helping!
DorMiX



Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 63
Re: Menubar does not appear after building
« Reply #1 on: June 02, 2017, 01:50:57 pm »
All menu bars are fused with the top screen bar under Unity. #BlameUnity

Offline DorMiX

  • Single posting newcomer
  • *
  • Posts: 2
Re: Menubar does not appear after building
« Reply #2 on: June 05, 2017, 11:40:33 am »
Thanks!  :)
OMG!  ;)
I feel totally embarrassed about Unitiy yet.  :o :P :-[