Author Topic: Process Terminated with Status 127  (Read 567 times)

Offline davidklecker

  • Single posting newcomer
  • *
  • Posts: 4
Process Terminated with Status 127
« on: April 01, 2017, 04:34:27 pm »
I'm getting a strange error that hopefully someone might be able to help me troubleshoot. Let's start with the basic setup that I have. I'm using Code:Blocks 13 on Ubuntu 16 LTS, and using wxWidgets 3.0.2. I have compiled wxWidgets under a basic setup with ../configure --enable-webview. My 'wx-config --cxxflags' and 'wx-config --lib all' do return the proper values from the terminal as does wx-config --version. I have also built a debug version for wxWidgets. I can create a basic wxWidgets application. It compiles, links, and executes. I have my global variables defined correctly and the build options I believe are okay.

The issue stems from trying to build and execute my application. It compiles, it links but it quits immediately on status 127. I looked into this status which tells me that there is a problem with my $PATH or a typo which is cryptic. I see that sometimes people forget to include g++ and status 127 tells them of this disconnect. That's not issue with me. In fact Code::Blocks doesn't tell me anything related to what may be going on. There are a few clues though that might help.

If I use `wx-config --libs all` for my linker properties when building, I get a strange error: "cannot find -lwx_gtk2u_media-3.0" This is strange because I don't believe I am using code that would need this library or I would see that when linking and it would tell me the methods that are undefined. Now I checked and I do not have media-3.0 as a library. I do have the development library installed on this machine so I am at a loss why this is coming up.

Now if I just put the contents of wx-config --libs all into the linker properties I get a different error. I get a process terminated on status 127. I think the two issues are related somehow but I'm not sure which direction to head to troubleshoot and resolve it.


Offline stahta01

  • Lives here!
  • ****
  • Posts: 5933
    • My Best Post
Re: Process Terminated with Status 127
« Reply #1 on: April 02, 2017, 12:12:53 am »
On the command line,

What does this return?
Code: [Select]
which wx-config

For me it returns this.
Code: [Select]
/usr/bin/wx-config

Tim S.
« Last Edit: April 02, 2017, 12:18:43 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5933
    • My Best Post
Re: Process Terminated with Status 127
« Reply #2 on: April 02, 2017, 12:17:55 am »
Once you get wx-config so it returns the correct location with which.

Then, using this to select the correct wxWidgets installation can be done. Edit: Also see link http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Linux
Code: [Select]
update-alternatives --config wx-config

Tim S.
« Last Edit: April 02, 2017, 12:21:18 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7207
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Process Terminated with Status 127
« Reply #3 on: April 02, 2017, 12:39:07 am »
Do you have xterm installed ?
If not do so or make sure, that you have a valid "Terminal to launch ..." set in "Settings -> Environment-> General settings".