Author Topic: Failed to import file: Wrong file format.  (Read 451 times)

Offline gansopro

  • Single posting newcomer
  • *
  • Posts: 3
Failed to import file: Wrong file format.
« on: March 23, 2017, 11:15:00 pm »
I downloaded the PS2 emulator source code from its official website first to study it. And it has a file called "PCSX2_suite.sln", which is your project file and opened normally. And you know that Code Blocks opens Solution Files from Visual Studio. So, I downloaded the source code of the same emulator of the site "GitHub" and when I open that file it appears that error message from above. Then you ask me: So, why do not you study what you downloaded from the official website? Then I answer: because I want to study the source code of the PS3 emulator and it is not found on its official website, only on the site "GitHub" and it also gives the same problem. How to correct this error?

Note 1: When I open that file in Code Blocks it first asks if I want to import the projects to use the default compiler, then it asks if I want to import all the settings of the imported projects, and I say yes to both.

Note 2: I'm from Brazil and I do not understand almost anything of English, to be doing this post I'm using Google Translate.

Offline sodev

  • Multiple posting newcomer
  • *
  • Posts: 96
Re: Failed to import file: Wrong file format.
« Reply #1 on: March 23, 2017, 11:38:00 pm »
This is apparently a Visual Studio 2015 Solution file, CodeBlocks latest supported Visual Studio Version is 2010, so i assume it can't convert newer files as well. Just use Visual Studio 2015 instead, there is a free version available.

Offline gansopro

  • Single posting newcomer
  • *
  • Posts: 3
Re: Failed to import file: Wrong file format.
« Reply #2 on: March 24, 2017, 12:40:39 am »
So what IDE do I use to open this file?

Offline raynebc

  • Almost regular
  • **
  • Posts: 135

Offline gansopro

  • Single posting newcomer
  • *
  • Posts: 3
Re: Failed to import file: Wrong file format.
« Reply #4 on: March 24, 2017, 12:59:41 am »
Thank you friend.