Developer forums (C::B DEVELOPMENT STRICTLY!) > Development

expat installed but the functions aren't recognized

(1/2) > >>

shadowlordCefet:
I had installed the expat library (last version) but when I try to use it I received an error "undefined reference" to all functions of this library. What I'm missing ?

Regard.

BlueHazzard:
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

you have to add the libraries to the linker options...

stahta01:

--- Quote from: BlueHazzard on March 19, 2017, 09:35:09 pm ---you have to add the libraries to the linker options...

--- End quote ---

http://wiki.codeblocks.org/index.php/FAQ-Compiling_%28errors%29#Q:_What_do_I_need_to_know_when_using_3rd_party_libs.3F

Tim S.

shadowlordCefet:
Hi Tim,

I inserted the folder where are the files in the compiler settings, but this package there's no lib files to insert in the linker settings (at least, I don't found any lib file).

stahta01:

--- Quote from: shadowlordCefet on March 20, 2017, 07:24:51 pm ---Hi Tim,

I inserted the folder where are the files in the compiler settings, but this package there's no lib files to insert in the linker settings (at least, I don't found any lib file).

--- End quote ---

Then you need to find a website that supports your compiler or the library you are trying to use!

This website only supports the Code::Blocks IDE/Editor and supports no compilers.

This website also does NOT teach programming. As stated in the rules http://forums.codeblocks.org/index.php/topic,9996.0.html

Tim S.

Navigation

[0] Message Index

[#] Next page

Go to full version