Author Topic: Check Boxes in properties not displaying check, Version 16.01 on Ubuntu 16.04  (Read 1713 times)

Offline Aaron

  • Multiple posting newcomer
  • *
  • Posts: 57
Is anyone else having this minor issue?

The check box squares in the properties pane does not display the actual check mark, but they do enable and disable their features.
In Ver 16.01 under Windows they operate as expected.

A bit annoying for visually impaired users I'm helping.

Is this a known issue or anomaly?
« Last Edit: March 18, 2017, 11:23:10 pm by Aaron »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5991
    • My Best Post
There seems to be a desktop under Ubuntu that causes a lot of GUI related bugs. I think it was called Unity or something like that.
No idea if this is one of the bugs.

I suggest posting the desktop info on your system.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
OS/distro, C::B version, screenshot?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Aaron

  • Multiple posting newcomer
  • *
  • Posts: 57
CodeBlocks Version 16.01 on Ubuntu 16.04.

Desktop may be Unity.

« Last Edit: March 20, 2017, 04:23:50 am by Aaron »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
You're talking about Is member and default pos and similar, aren't you?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Aaron

  • Multiple posting newcomer
  • *
  • Posts: 57
Yes
Is Member, Default Position, Default Size, Enabled, etc.

These all display the check mark inside the square in Windows PC Code Blocks installs.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Are there any other ubuntu users that have the same problem?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 75
Ubuntu

Are you missing some fonts?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Commaster: What ubuntu is this screenshot from?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 75
Commaster: What ubuntu is this screenshot from?
Code: [Select]
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.2 LTS
Release:        16.04
Codename:       xenial

Offline CJS

  • Multiple posting newcomer
  • *
  • Posts: 11
I checked this on Ubuntu 14.04.5 LTS 64-bit and Ubuntu 16.04.2 LTS 64-bit (VirtualBox VMs), with a simple test and a more complex app and check marks were displayed as expected, e.g. on Panel1 in the wxSmith heirarchy.

CB: Release 16.01 rev 10760 (2016-02-01 01:39:02) gcc 5.3.1 Linux/unicode - 64 bit

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"

Observations:

There are changes in gtk versions between Ubuntu LTS versions:

Ubuntu 14.04.5 LTS:
libgtk2.0-0:
  Installed: 2.24.23-0ubuntu1.4
libgtk-3-0:
  Installed: 3.10.8-0ubuntu1.6

Ubuntu 16.04.2 LTS:
libgtk2.0-0:
  Installed: 2.24.30-1ubuntu1
libgtk-3-0:
  Installed: 3.18.9-1ubuntu3.2

I don't see any mention of whether the problem was seen on a 32-bit or 64-bit Ubuntu / CB - it might have a bearing.

Offline Miguel Gimenez

  • Multiple posting newcomer
  • *
  • Posts: 54
Checked OK on 16.04.2 64-bit with Gnome 3 and Punity desktops

Offline Aaron

  • Multiple posting newcomer
  • *
  • Posts: 57
Quote
Are there any other ubuntu users that have the same problem?

Of 3 Ubuntu PCs, one is missing the check marks.

Quote
Are you missing some fonts?

Counted 96 Fonts on Ubuntu. 53 fonts in Win 7.

Quote
I don't see any mention of whether the problem was seen on a 32-bit or 64-bit Ubuntu / CB - it might have a bearing.

64 Bit, all
« Last Edit: March 23, 2017, 03:46:43 am by Aaron »

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 75
Of 3 Ubuntu PCs, one is missing the check marks.
Can you (backup and ) delete ~/.config/codeblocks then run Code::Blocks and check the checkmarks?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10404
Interesting - are they the same hardware?
And are they fully updated ubuntus? Same ubuntu version?
Can you look in the Help -> About dialog and check if the version strings there match?

Can you tell me what wx version is used?
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]