Author Topic: Installing Code::Blocks on openSUSE Leap 42.1  (Read 1451 times)

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Installing Code::Blocks on openSUSE Leap 42.1
« on: March 04, 2017, 01:17:05 pm »
Hello,

I downloaded codeblocks-16.01.suse_Leap_42.1.x86_64.tar.xz and extracted it. It has lots of rpm files. Then I typed rpm -ivh *.rpm. It gave me error. I can't post it here because of 20000 characters limit. It is attached.

Any help is appreciated.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10399
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #1 on: March 04, 2017, 02:54:21 pm »
You need to install wxgtk 2.8 packages. Probably they are provided by the SUSE project. If they are not these rpms are useless.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #2 on: March 06, 2017, 11:59:11 am »
Thank you. I downloaded the source code. And I follow the instructions (http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Linux#Code::Blocks_installation) to install it. First it says I must have wxWidgets. So I downloaded and installed it. But here I'm confused:

Quote
Library wxGTK installation
Checking the presence of libwxGTK library

In your package manager, look for 'libwxgtk' keyword and verify that all libwxgtk2.8 stuffs are installed. If you find the libraries uninstalled, just install them and go directly to Code::Blocks installation.

Alternatively you can do the same in the command line (the following is an example, there may be more than two packages):

Code: [Select]
$ ls /usr/lib/libwx_gtk* //to verify the presence
$ sudo apt-get install libwxgtk2.8-dev
$ sudo apt-get install libwxgtk2.8-0


I can't find libwxgtk. I tried the first line above. Then it gave me this:

Code: [Select]
ls: cannot access /usr/lib/libwx_gtk*: No such file or directory
But I'm sure I installed wxWidgets. Because I followed the instructions of https://wiki.wxwidgets.org/Compiling_and_getting_started.  And I checked it via typing wx-config --version. It gave me 3.0.2.

Best regards.
« Last Edit: March 06, 2017, 12:02:15 pm by ujbej »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5988
    • My Best Post
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #3 on: March 06, 2017, 02:22:47 pm »
Thank you. I downloaded the source code. And I follow the instructions (http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Linux#Code::Blocks_installation) to install it. First it says I must have wxWidgets. So I downloaded and installed it. But here I'm confused:

Quote
Library wxGTK installation
Checking the presence of libwxGTK library

In your package manager, look for 'libwxgtk' keyword and verify that all libwxgtk2.8 stuffs are installed. If you find the libraries uninstalled, just install them and go directly to Code::Blocks installation.

Alternatively you can do the same in the command line (the following is an example, there may be more than two packages):

Code: [Select]
$ ls /usr/lib/libwx_gtk* //to verify the presence
$ sudo apt-get install libwxgtk2.8-dev
$ sudo apt-get install libwxgtk2.8-0


I can't find libwxgtk. I tried the first line above. Then it gave me this:

Code: [Select]
ls: cannot access /usr/lib/libwx_gtk*: No such file or directory
But I'm sure I installed wxWidgets. Because I followed the instructions of https://wiki.wxwidgets.org/Compiling_and_getting_started.  And I checked it via typing wx-config --version. It gave me 3.0.2.

Best regards.

Decide what you are trying to do!!!

Build Code::Blocks yourself?
Or install precompiled Code::Blocks from where-ever you found the RPMs?

Tim S.

C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #4 on: March 06, 2017, 03:01:41 pm »
openSUSE RPM's are not working properly. So I decided to build by source code.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5988
    • My Best Post
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #5 on: March 06, 2017, 03:09:10 pm »
Most Linux Distros use wxWidgets 3.0.2 now; So, building Code::Blocks with wxWidgets 3.0.2 is normal.

What are you confused about?

Edit: No idea if the Debian Linux steps you tried to use will work on openSUSE; I would guess the answer is NO.

Tim S.
« Last Edit: March 06, 2017, 03:11:16 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #6 on: March 06, 2017, 03:22:38 pm »
As I said earlier, I get improper feedback from the console:

I typed: 
Code: [Select]
$ ls /usr/lib/libwx_gtk* //to verify the presence]
But here is the feedback:
Code: [Select]
ls: cannot access /usr/lib/libwx_gtk*: No such file or directory
I typed:
Code: [Select]
sudo apt-get install libwxgtk2.8-dev

I got:
Code: [Select]
Loading repository data...
Reading installed packages...
'libwxgtk2.8-devel' not found in package names. Trying capabilities.
No provider of 'libwxgtk2.8-devel' found.
Resolving package dependencies...

Nothing to do.


EDIT: These are the instructions on the wiki page: http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Linux#Code::Blocks_installation

Offline stahta01

  • Lives here!
  • ****
  • Posts: 5988
    • My Best Post
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #7 on: March 06, 2017, 03:31:36 pm »
I give up you need a openSUSE expert to tell you if Debian package management command of apt-get works on your distro!

Why do you NOT use the wxWidgets 3.0.2 that you said was already installed?
Instead of trying to install 2.8 version of wxWidgets/wxGTK.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #8 on: March 06, 2017, 03:39:11 pm »
I use openSUSE because of  my job. And I am linux newbie. Of course I'll use wxWidgets 3.0.2 if I can. I just follow the instructions. 

Offline sodev

  • Multiple posting newcomer
  • *
  • Posts: 108
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #9 on: March 06, 2017, 03:54:46 pm »
Then use the system for which these intructions are made for ;D. Apparently your system also uses apt-get but the package names are maybe different. Or you need to enable additional package sources. This is not a CodeBlocks problem but an openSUSE problem, better ask in a forum dedicated to openSUSE how to get a wxWidgets 2.8 package.

Offline ujbej

  • Single posting newcomer
  • *
  • Posts: 6
Re: Installing Code::Blocks on openSUSE Leap 42.1
« Reply #10 on: March 06, 2017, 03:57:27 pm »
Thank you  :)