Author Topic: toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared  (Read 2465 times)

Offline alexbour

  • Multiple posting newcomer
  • *
  • Posts: 10

rm -f sdk_precomp.h.gch
g++ -std=c++11 -DHAVE_CONFIG_H  -I/usr/lib64/wx/include/gtk2-unicode-3.0 -I/usr/include/wx-3.0 -D_FILE_OFFSET_BITS=64 -DwxDEBUG_LEVEL=0 -DWXUSINGDLL -D__WXGTK__ -pthread -I../../src/include -I../../src/include -I../../src/sdk/wxscintilla/include -I../../src/include/scripting/sqplus -I../../src/include/mozilla_chardet -I../../src/include/mozilla_chardet/mfbt -I../../src/include/mozilla_chardet/nsprpub/pr/include -I../../src/include/mozilla_chardet/xpcom -I../../src/include/mozilla_chardet/xpcom/base -I../../src/include/mozilla_chardet/xpcom/glue -DCB_AUTOCONF  -DCB_PRECOMP -DPIC -I../../src/include/tinyxml -DTIXML_USE_STL=YES  -O2 -ffast-math  -Winvalid-pch -fPIC -fexceptions -o sdk_precomp.h.gch -xc++-header ./sdk_precomp.h
In file included from ./sdk_common.h:144:0,
                 from ./sdk_precomp.h:13:
./toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared
   void DoRemoveTool(ToolsList::Node* node);
 


The system is open suse.


Offline stahta01

  • Lives here!
  • ****
  • Posts: 6948
    • My Best Post
Re: toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared
« Reply #1 on: February 24, 2017, 04:10:17 am »
Was wxWidgets compiled with STL mode as true?
Note: STL mode as true means wxUSE_STL=1 or --enable-stl was given to build wxWidgets.

On windows, the last time I had that error it was because C::B was NOT yet supporting wxWidgets with  STL mode as true.

wxWidgets version? Edit: Posted log said version 3.0.2.
And were did you get it? Self-built or system built?
Edit: Code::Blocks version being compiled? Edit: Posted log said Found revision: '11019' '2017-02-21 23:52:17'

Tim S.
« Last Edit: February 24, 2017, 04:15:02 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6948
    • My Best Post
Re: toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared
« Reply #2 on: February 24, 2017, 04:36:16 am »
From https://en.opensuse.org/openSUSE:Packaging_wxWidgets#STL_variant

Code: [Select]
STL variant

wxWidgets-devel with STL interface and Unicode is a new ABI recommended by upstream.
wx container variant

wxWidgets-wxcontainer-devel with the old wx container interface and Unicode support is now deprecated.

Looks like you have a choice of two or more packages, which did you use?

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline alexbour

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared
« Reply #3 on: February 25, 2017, 06:05:16 pm »
Following forum suggestions, I eliminated stl version of wxwidgets by compiling a fresh one, taken from git repository
then I tryied to compile c:B again, new errors appear, see attachment log2.txt  as a result of the next command
clear ; ./configure --with-wx-prefix=/opt/bin --enable-shared  --prefix=/opt --with-contrib-plugins=all && make
Below are commands used to compile wxwidgets:
./autogen.sh

./build/update-setup-h
cd build
.
Quote
./configure --with-gtk=3  --with-pic=yes    --without-gtkprint     --disable-stl    --with-cxx=11 --enable-shared --disable-static         --target=elf_x86_64 --enable-debug_info  --enable-compat28 -enable-unicode --prefix=/opt   && make clean && make && make install

Offline alexbour

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: toolsmanager.h:46:32: error: ‘ToolsList::Node’ has not been declared
« Reply #4 on: February 25, 2017, 09:39:57 pm »
OK! Finaly I compiled C:B below are steps in short
1. remove wxwidgetsgtk  from installed packages on open suse system
2. checkout fresh wxwidgets
git clone https://github.com/wxWidgets/wxWidgets.git some_folder
cd some_folder
3. install wxWidgets:
./autogen.sh
./build/update-setup-h
cd build
../configure --with-gtk=3  --with-pic=yes    --without-gtkprint     --disable-stl    --with-cxx=11 --enable-shared --disable-static         --target=elf_x86_64 --enable-debug_info  --enable-compat28 -enable-unicode --prefix=/opt   && make clean && make && sudo make install
4. checkout fresh c:B in my case it was svn rev. 11019
5make sure prerequisites requirements are satisfied
./bootstrap
6 configure:
/configure --with-wx-prefix=/opt/bin--enable-shared  --prefix=/opt --with-contrib-plugins=all
##note /opt - rootfolder  where wx widgets was installed  and /opt/bin - where wx-config lives (in your case could be different)
7 make and make install
8 enjoy freshly  built c:B
9. Thank creators and developers of C:B
Good luck,
AB.