Author Topic: Can't find compiler executable gnu gcc  (Read 252 times)

Offline Quentho

  • Single posting newcomer
  • *
  • Posts: 2
Can't find compiler executable gnu gcc
« on: February 17, 2017, 12:37:50 pm »
Hi, Code::Blocks always give me this error after many install/ re-install... i'have ever tried in the toolchain executables to auto detect and ever try to install by myself a compiler : always the same résult "Can't find compiler executable gnu gcc". Please i need help, i have to run code::Blocks for school

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1186
Re: Can't find compiler executable gnu gcc
« Reply #1 on: February 17, 2017, 02:04:02 pm »
have you installed a compiler?
what operating system are you using?

Offline Quentho

  • Single posting newcomer
  • *
  • Posts: 2
Re: Can't find compiler executable gnu gcc
« Reply #2 on: February 20, 2017, 01:25:12 pm »
Ok in order, what i've done :

-install codeblocks-16.01mingw-setup.exe (86.6 MO)
-try to change in toolchain executables the Compiler's installation directory with the auto-detect. It did'nt work so i search on google and i try to change in toolchain executables the Compiler's installation directory by C:\Program Files (x86)\CodeBlocks\MinGW and it did'nt work to.
-So uninstall and install codeblocks-16.01-setup.exe (32.9MO) and a compiler tdm64-gcc-5.1.0-2. In the toolchain executables put C:\TDM-GCC-64 and it did'nt work to...


I use Windows 10

So what can i do now ?

Thanks you

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1186
Re: Can't find compiler executable gnu gcc
« Reply #3 on: February 20, 2017, 02:26:53 pm »
The way you described is correct and it should work... I have no idea how i can help you future...
Have you tried to set the Path to the bin sub folder?
If you select the path to the compiler by yourself don't hit the autodetect button again!!
If you use tdm64-gcc do the executables have a other name then in the settings? You can try to select every tool in the compiler settings by hand...

Have you installed a anti virus program? Can you try to deactivate it?