Author Topic: codeblocks wxwidget script error  (Read 741 times)

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
codeblocks wxwidget script error
« on: February 17, 2017, 05:49:52 am »
HI,

I am working on building wxwidget project on codeblocks. I am using wxWidget 2.8.12, Codeblocks 16.01.
I build wxwidget libraries in the configuration SHARED=1, MONOLITHIC=1, UNICODE=1. Also using the same wxwidget, I build the codeblocks sdk code also successfully. So I am sure that wxwidget buildup is fine.

Now, when I try to create a wxwidget project in codeblocks, It gave me error that script error has occurred.
Can anyone help? I need to learn wxwidget project building so as to use it in creating plugin

Note: while creating wxwidget project I checked wxwidgetDLL, unicode and monolithic options in the options given by wxwizard in codeblocks

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #1 on: February 17, 2017, 06:05:52 am »
Did you edit the wizard.script file?

Tim S.
« Last Edit: February 17, 2017, 06:08:34 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #2 on: February 17, 2017, 06:12:43 am »
What compiler are you using?
And, what is the default CB Compiler?

Edited info below this line to help answer the above questions.
NOTE: For the above compiler names I would like the logical CB compiler titles/names like these below:
"GNU GCC Compiler"
"Microsoft Visual C++ 2010"
"Borland C++ Compiler (5.5, 5.82)"
"OpenWatcom (W32) Compiler"

Tim S.
« Last Edit: February 17, 2017, 06:21:32 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #3 on: February 17, 2017, 06:39:57 am »
Quote
Did you edit the wizard.script file?
No, I didn't edit the wizard.script file for wxwidget

Quote
What compiler are you using?
And, what is the default CB Compiler?

I am using GNU GCC Compiler and it is the default compiler as well
Quote
"GNU GCC Compiler"
For GNU GCC Compiler, I am using MINGW Compiler 5.3.0


Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #4 on: February 17, 2017, 07:19:03 am »
Some additional information that I would like to share,

I have first downloaded codeblocks sdk code from svn repo at codeblocks.org/sources, I downloaded wxwidget2.8.12 build it in Dynamic library, monolithic and unicode configuration. Then I tried to build this codeblocks svn code [ Note: I build only codeblocks.cbp but not codeblocks.workspace] based on this wxwidget. I ran update.bat file. Then I open the generated codeblock.exe and I tried to create plugin and install the plugin.. it works fine. Then I tried to create wxsmith panel for that plugin it works fine. Problem occurs only when I tried to build wxwidget project on this codeblocks.
I hope building only codeblocks.cbp but not codebloblocks.workspace won't be a problem?

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #5 on: February 17, 2017, 07:56:30 am »
I will try to build Code::Blocks tomorrow; been a few months since I last built Code::Blocks the normal way.
And, I forget when I last used the wxWidgets script with version 2.8.12.
It might be broken.

Can you post a link to your Compiler download site?

It might be a Compiler related issue; but, I consider that only a slight possibility.

Otherwise, I will likely just build with TDM GCC 4.7.1 compiler or TDM GCC 5.1.0 compiler.

NOTE: You do know that wxWidgets 2.8.12 does NOT support being built as 64 bit on Windows?

I have no idea what bugs happen if it compiled as 64 bit or if it is compiled using an MinGW-64 based GCC.

Tim S.
   
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #6 on: February 17, 2017, 08:05:57 am »
Quote
Can you post a link to your Compiler download site?

It might be a Compiler related issue; but, I consider that only a slight possibility.

I dont remember the link but it was compiler 5.3.0 version. Maybe this link https://sourceforge.net/projects/mingw-w64/

Quote
NOTE: You do know that wxWidgets 2.8.12 does NOT support being built as 64 bit on Windows?
I didn't know that but thanks for info

Quote
I will try to build Code::Blocks tomorrow;
Thanks a lot, I want to setup everything once, so that I can start development

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #7 on: February 17, 2017, 08:39:15 am »
Hi Tim,

I tried to create the wxwidget project from binary downloaded from here "http://www.codeblocks.org/downloads/26"
and wxwidget project gets created successfully. I tried to build and run, that also works fine.

I then open my svn codeblocks->codeblocks.exe and try to create a wxwidget project again..Voila it build up fine without any script error, that I mentioned, May be restarting codeblocks solve the purpose.

Anyways, if you are building codeblocks from its sdk, it will be really helpful Thanks

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #8 on: February 17, 2017, 07:30:07 pm »
Code: [Select]
C:\Program Files\mingw-w64\i686-5.3.0-win32-sjlj-rt_v4-rev0\mingw32\bin>gcc --version
gcc (i686-win32-sjlj-rev0, Built by MinGW-W64 project) 5.3.0

Installed the above Compiler; will be a while before I get time to build wxWidgets 2.8.12 and CB SVN.

FYI: I believe the above compiler will NOT work right if a different mingw GCC compiler is installed in "c:/mingw32".

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #9 on: February 20, 2017, 05:06:20 am »
Quote
I believe the above compiler will NOT work right if a different mingw GCC compiler is installed in "c:/mingw32".

I didn't get it.

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #10 on: February 20, 2017, 10:59:56 am »
Quote
I believe the above compiler will NOT work right if a different mingw GCC compiler is installed in "c:/mingw32".

I didn't get it.

Do YOU have a mingw GCC compiler is installed in "c:/mingw32"?
If yes, then the Compiler you are trying to use will NOT work correctly unless it is the Compiler installed in "c:/mingw32".

NOTE: The drive letter of "C:" could be any drive letter on your computer instead like "D:".

I am working on deleting stuff from my computer in order to build Code::Blocks in the normal way.
I will then try to duplicate your issue.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anandamu16

  • Multiple posting newcomer
  • *
  • Posts: 85
Re: codeblocks wxwidget script error
« Reply #11 on: February 20, 2017, 12:33:40 pm »
My Mingw compiler is installed in "c:/MINGW"
Ok, Fine. As stated earlier, my issue has been resolved after restarting codeblocks.

Thanks

Online stahta01

  • Lives here!
  • ****
  • Posts: 5709
    • My Best Post
Re: codeblocks wxwidget script error
« Reply #12 on: February 21, 2017, 12:59:34 am »
I was able to confirm if you choose a compiler that is NOT one of the four types of Compilers supported by the wxWidgets wizard you get that script error. I would also guess it might happen if the Compiler has NOT been saved which happens on CB close.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org