Author Topic: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)  (Read 3073 times)

Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« on: February 12, 2017, 03:36:25 am »
I installed CodeBlocks on Ubuntu 16.10 using:

Code: [Select]
sudo apt install codeblocks
When I start CodeBlocks and then create a new console application, the CodeBlocks IDE will freeze if I start clicking on menu options (such as SETTINGS -> COMPILER, or SETTINGS -> ENVIRONMENT). The freeze doesn't always happen on the first attempt, although many times it does. It's very easy to reproduce and happens quite often (making CodeBlocks virtually unusable for me on Ubuntu 16.10).

The version of CodeBlocks is 16.01 rev 10692.


Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10118
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #1 on: February 12, 2017, 01:20:38 pm »
Can you give us a backtrace for the crash/lockup?

See here https://wiki.ubuntu.com/Backtrace how to do it.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #2 on: February 12, 2017, 07:41:01 pm »
Can you give us a backtrace for the crash/lockup?

See here https://wiki.ubuntu.com/Backtrace how to do it.

Hi oBFusCATed - I followed the instructions you linked to:

1. Turned off apport then rebooted.
2. Ran CodeBlocks via gdb as per the instructions.
3. Created a new console application called Test3.
4. Clicked on Settings | Environment.

Result: the environment dialog is displayed, but freezes (see attached screenshot).

Note: I have noticed that this freezing doesn't occur when no project is opened.

I'm going to perform a fresh install of Ubuntu 16.04 on a different computer and see if the problem still occurs.

Offline yvesdm3000

  • Almost regular
  • **
  • Posts: 225
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #3 on: February 12, 2017, 07:46:51 pm »
You should type "bt"  (withhout quotes) to show the backtrace in gdb

Yves
Clang based code completion for Code::Blocks:   http://github.com/yvesdm3000/ClangLib

Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #4 on: February 12, 2017, 07:58:37 pm »
Update: I have just tried to reproduce the problem on a laptop running Kubuntu 16.10, but was not able to - everything worked as expected.

I will try again on a clean install of Ubuntu 16.10 and a clean install of Ubuntu 16.04.

Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #5 on: February 12, 2017, 08:14:18 pm »
You should type "bt"  (withhout quotes) to show the backtrace in gdb

Yves

Hi Yves - I have run "bt" within gdb as you instructed and have attached the results. This time, it froze on Settings | Compiler.


Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #6 on: February 12, 2017, 10:44:07 pm »
I performed a clean install of Ubuntu 16.10, ran all the updates, then installed CodeBlocks. The problem persists, the gdb backtrace is attached.

Again, I was unable to reproduce the issue on Kubuntu 16.10.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1415
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #7 on: February 12, 2017, 11:36:46 pm »
Can you try to disable the symbol browser?
Before loading a project: Settings->Editor->Code Completion->Symbol browser->Disable symbol browser


Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #8 on: February 12, 2017, 11:50:14 pm »
Can you try to disable the symbol browser?
Before loading a project: Settings->Editor->Code Completion->Symbol browser->Disable symbol browser

Tried disabling the symbol browser, the problem persists. I tried to BUILD | CLEAN the default console application, and it froze. I then did a killall codeblocks (seems to be the only way to close Code::Blocks when this issue occurs) and tried SETTINGS | ENVIRONMENT, and it froze again.

Offline scott.deagan

  • Single posting newcomer
  • *
  • Posts: 9
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #9 on: February 13, 2017, 02:22:03 pm »
I performed a clean install of Ubuntu 16.04.1 LTS, ran all the updates, then installed Code::Blocks from the repositories using:

Code: [Select]
sudo apt install codeblocks
This installed Code::Blocks release 13.12 rev 9501.

Again, I created a new console application, opened the generated main.cpp file, then iteratively clicked through the SETTINGS menu options (Environment, Editor, Compiler, Debugger, Global Variables, Scripting...).

The gdb backtrace is attached.
« Last Edit: February 13, 2017, 02:45:01 pm by scott.deagan »

Offline nanyu

  • Almost regular
  • **
  • Posts: 187
  • nanyu
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #10 on: February 13, 2017, 03:00:35 pm »
me too :
see :
  http://forums.codeblocks.org/index.php/topic,21739.0.html



1.  this bug was happen before one year ago.
2.  I have disabled all plugin.
2.  I didn't open or create new project. just launch c::b .
« Last Edit: February 16, 2017, 08:43:10 am by nanyu »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7191
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #11 on: February 13, 2017, 06:39:50 pm »
I will set up  a vm with 16.10 and try to reproduce.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10118
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #12 on: February 13, 2017, 08:18:02 pm »
@scott.deagan: You've hit some of the nasty bugs, I have no idea how to fix :( There is an old discussion on the wx mailing list about this problem https://groups.google.com/forum/#!topic/wx-dev/r_QdyEzoM4I No time to read it fully to find out if they've found a solution, probably not.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1415
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #13 on: February 14, 2017, 03:29:30 pm »
can you give more info why you think their problem is related to this mailing list entry? As far as i can see it handles only the clipboard?
And why is this error only on ubuntu and not on mint or other debian based systems? I tried ubuntu in a vm and it seems that wxWidgets has more problems on ubuntu.. I got many repaint issues (toolbar disappearing, borders not drawn correctly) I used a fresh build of wx3.1 with gtk3 (i tested only a few minutes, don't have time to investigate there at the moment)...

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7191
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Codeblocks not working well on Ubuntu 16.10 (keeps freezing)
« Reply #14 on: February 14, 2017, 11:11:23 pm »
I just tried on ubuntu 16.10, self-compiled C::B from trunk.
Compiled against system wxWidgets (3.02) and don't have visual issues (except the cursors over the toolbat-grips, which is known) and no crashes.
Symbolsbrowser is active and I currently compile the wx30 unix workspace.

Which DE do you use ?
The (in my opinion) nearly unusable unity ?

I tested it with gnome-shell and if that makes the difference, the ubuntu devs have created a pretty broken desktop environment.