Author Topic: wxSmith plugin is not loaded, can not continue  (Read 1743 times)

Offline Grouch

  • Multiple posting newcomer
  • *
  • Posts: 40
wxSmith plugin is not loaded, can not continue
« on: January 07, 2017, 10:47:16 pm »
After years of satisfactory use of Code::Blocks (CB) with wxSmith on a 32-bit system with Ubuntu Linux, I got a new 64-bit system, installed Ubuntu and CB, copied over CB projects, re-built, and they ran fine. Then I wanted to start a new CB-with-wxSmith project, but I could not. As soon as I clicked the button to create the project, I got the message " wxSmith plugin is not loaded, can not continue."

I searched for this message in the forums and found a fellow with the same problem and a message from Jens reading "Run  ./configure --help to see which options are available."

I ran both
  ./configure
and
  ./configure --help
but got nothing.

Maybe I am now supposed to install wxSmith separately from CB, but precisely how I have not been able to figure out.
An explicit explanation would be most appreciated.

 Also various forum posts indicate problems with the first wxSmith tutorial with recent versions of CB. The problem was not, it seems, in the tutorial but in the CB-wxSmith combination. Have these been fixed?

Many thanks.




 

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6535
    • My Best Post
Re: wxSmith plugin is not loaded, can not continue
« Reply #1 on: January 07, 2017, 10:58:15 pm »
Did you install the CB Contrib Plugins?
Edit2: Link http://packages.ubuntu.com/search?keywords=codeblocks-contrib

If not, do so.

Why are you trying to build CB instead of installing the package for your system?

Tim S.
« Last Edit: January 07, 2017, 11:00:54 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Grouch

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: wxSmith plugin is not loaded, can not continue
« Reply #2 on: January 08, 2017, 03:02:52 am »
Thanks, Tim.
I had installed CodeBlocks from the Ubuntu Software Center, but perhaps I had failed to check the box for "contributed plugins" when I did so. I removed CodeBlocks, then re-installed it, being careful to click this box, which you have to scroll down to see. The problem seems to be fixed.

Clopper

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2360
Re: wxSmith plugin is not loaded, can not continue
« Reply #3 on: January 08, 2017, 10:08:02 pm »
If someone else has the same problem:
You can also post install the contrib plugins in the synaptic packet manager, or via apt-get by installing the codeblocks contrib package. just search for it...