Author Topic: wxWidgets  (Read 1587 times)

Offline Papa

  • Single posting newcomer
  • *
  • Posts: 1
wxWidgets
« on: December 26, 2016, 06:49:47 pm »
WX      : wxWidgets-3.1.0
OS      : Windows 10
g++ -v  :
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=C:/unix/mingw-w64/mingw64/bin/../libexec/gcc/x86_64-w64-mingw32/6.2.0/lto-wrapper.exe
Target: x86_64-w64-mingw32
Configured with: ../../../src/gcc-6.2.0/configure --host=x86_64-w64-mingw32 --build=x86_64-w64-mingw32 --target=x86_64-w64-mingw32 --prefix=/mingw64 --with-sysroot=/c/mingw620/x86_64-620-posix-seh-rt_v5-rev1/mingw64 --enable-shared --enable-static --disable-multilib --enable-languages=c,c++,fortran,lto --enable-libstdcxx-time=yes --enable-threads=posix --enable-libgomp --enable-libatomic --enable-lto --enable-graphite --enable-checking=release --enable-fully-dynamic-string --enable-version-specific-runtime-libs --enable-libstdcxx-filesystem-ts=yes --disable-isl-version-check --disable-libstdcxx-pch --disable-libstdcxx-debug --enable-bootstrap --disable-rpath --disable-win32-registry --disable-nls --disable-werror --disable-symvers --with-gnu-as --with-gnu-ld --with-arch=nocona --with-tune=core2 --with-libiconv --with-system-zlib --with-gmp=/c/mingw620/prerequisites/x86_64-w64-mingw32-static --with-mpfr=/c/mingw620/prerequisites/x86_64-w64-mingw32-static --with-mpc=/c/mingw620/prerequisites/x86_64-w64-mingw32-static --with-isl=/c/mingw620/prerequisites/x86_64-w64-mingw32-static --with-pkgversion='x86_64-posix-seh-rev1, Built by MinGW-W64 project' --with-bugurl=http://sourceforge.net/projects/mingw-w64 CFLAGS='-O2 -pipe -I/c/mingw620/x86_64-620-posix-seh-rt_v5-rev1/mingw64/opt/include -I/c/mingw620/prerequisites/x86_64-zlib-static/include -I/c/mingw620/prerequisites/x86_64-w64-mingw32-static/include' CXXFLAGS='-O2 -pipe -I/c/mingw620/x86_64-620-posix-seh-rt_v5-rev1/mingw64/opt/include -I/c/mingw620/prerequisites/x86_64-zlib-static/include -I/c/mingw620/prerequisites/x86_64-w64-mingw32-static/include' CPPFLAGS= LDFLAGS='-pipe -L/c/mingw620/x86_64-620-posix-seh-rt_v5-rev1/mingw64/opt/lib -L/c/mingw620/prerequisites/x86_64-zlib-static/lib -L/c/mingw620/prerequisites/x86_64-w64-mingw32-static/lib '
Thread model: posix
gcc version 6.2.0 (x86_64-posix-seh-rev1, Built by MinGW-W64 project)


WxWidgets:
mingw32-make -f makefile.gcc CXXFLAGS="-std=c++11 -m64" CFG=64 CPP="gcc -E -D_M_AMD64" DEBUG_FLAG=1 BUILD=release UNICODE=1 MONOLITHIC=1 USE_OPENGL=1 RUNTIME_LIBS=static USE_RTTI=0 USE_EXCEPTIONS=1 BUILD=debug CXXFLAGS=-fno-keep-inline-dllexport 2>build.txt

*** build.txt is attached ***

Hello.
Using http://wiki.codeblocks.org/index.php?title=WxSmith_tutorial:_Hello_world, the tutorials, at the point of choosing $(#wx), I get an error that says:

Select a valid location

Obviously I have done something wrong, but I don't know what it could be.
Why is C::B not accepting $(#wx) as lib location, but when using C:\unix\wxWidgets-3.1.0, it proceed to the next choice?
Please note that I have added C:\unix\wxWidgets-3.1.0 to the global path.

Thanks for your help in advance

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6666
    • My Best Post
Re: wxWidgets
« Reply #1 on: December 26, 2016, 09:07:36 pm »
Obviously I have done something wrong, but I don't know what it could be.
Why is C::B not accepting $(#wx) as lib location, but when using C:\unix\wxWidgets-3.1.0, it proceed to the next choice?
Please note that I have added C:\unix\wxWidgets-3.1.0 to the global path.

What base location did you set for the Global Variable wx ?

Tim S.
 
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org