Author Topic: Problems with Python-Plugin  (Read 1449 times)

Offline Heiko

  • Single posting newcomer
  • *
  • Posts: 2
Problems with Python-Plugin
« on: October 10, 2016, 04:15:40 pm »
When installing/building the plugin from the project I get the message that this is inaccessible :

--    virtual void AddPendingEvent(const wxEvent& event)

I am new to Code::Blocks and maybe it is a very simple error..would just like to get it going..
Any help appreciated!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11040
    • Travis build status
Re: Problems with Python-Plugin
« Reply #1 on: October 10, 2016, 08:55:01 pm »
Please post the full build log. Also post which version of codeblocks are you using on which os and compiler.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Heiko

  • Single posting newcomer
  • *
  • Posts: 2
Re: Problems with Python-Plugin
« Reply #2 on: October 11, 2016, 12:10:40 am »
This is the build-message :
||=== Build: cbplugin in XmlRpcEmbedder (compiler: GNU GCC Compiler) ===|
/usr/include/wx-3.0/wx/event.h||In member function ‘void XmlRpcInstance::OnEndProcess(wxProcessEvent&)’:|
/usr/include/wx-3.0/wx/event.h|3387|error: ‘virtual void wxEvtHandler::AddPendingEvent(const wxEvent&)’ is inaccessible|
/home/heiko/Codeblocks_Python/codeblocks-python-master/XmlRpcEmbedder/xmlrpc_embedder.cpp|459|error: within this context|
||=== Build failed: 2 error(s), 0 warning(s) (0 minute(s), 2 second(s)) ===|

CodeBlocks Version is 16.01 on a Linux-Mint 17.3 64-Bit

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11040
    • Travis build status
Re: Problems with Python-Plugin
« Reply #3 on: October 11, 2016, 07:24:24 pm »
I guess the plugin is not ported to wx3.0.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]