Author Topic: changing the consolle  (Read 1271 times)

Offline alexo

  • Multiple posting newcomer
  • *
  • Posts: 21
changing the consolle
« on: September 29, 2016, 03:11:00 pm »
Hello everyone,
I run linux mint 17.3 and code::block 16.01 natively build from sources.
After linux mint updatěng - or maybe this is what I suspect - the execution consolle for a command line project hang after executing the executable.
I disinstalled it via make uninstal.
So I downloaded the windows binary install version of C::B 16.01 and got successfully running via wine - the windows emulator.
Now a problem appears. The shell consolle does'n load. This is the output I get if I try to execute the Hello World default project:

Code: [Select]

Checking for existence: Z:\home\alessandro\Documenti\ProgC\Mingw-compile-folder\Hello World\bin\Debug\Hello World.exe
Executing: "C:\Program Files\CodeBlocks/cb_console_runner.exe" "Z:\home\alessandro\Documenti\ProgC\Mingw-compile-folder\Hello World\bin\Debug\Hello World.exe"  (in Z:\home\alessandro\Documenti\ProgC\Mingw-compile-folder\Hello World\.)
Process terminated with status 0 (0 minute(s), 0 second(s))


The problem seems to be the cb_console_runner.exe that does'n start
Now I ask if there is a way to change the default consolle maybe using some from the OS (linux)

Thanks in advance,

Alessandro

Offline alexo

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: changing the consolle
« Reply #1 on: September 29, 2016, 11:31:50 pm »
in settings->environment->general settings
the last two fields are greyed and cannot be modified.
The string that appears on the first field is : /bin/sh  -c