Author Topic: C::B launch problem  (Read 1881 times)

Offline chao.mazda

  • Single posting newcomer
  • *
  • Posts: 3
C::B launch problem
« on: June 12, 2016, 04:17:54 am »
Hi everyone,

I was successful to compile C::B source code and install it on my Debian Jessie. It worked well. But a couple of days later, after installing Debian official update packages via Internet, my C::B does not start. I tried to run it by command line as, codeblocks -v. I obtained like this:


bash: codeblock: command not found
[email protected]:~/libs/wxWidgets-3.0.2/build$ codeblocks -v
Starting Code::Blocks Release 16.01  rev 10692 Jun 11 2016, 21:37:20 - wx3.0.2 (Linux, unicode) - 64 bit
Initialize EditColourSet .....
Initialize EditColourSet: done.
Loading menubar...
Debugger: loaded
OpenFilesList: loaded
OccurrencesHighlighting: loaded
ProjectsImporter: loaded
Autosave: loaded
ToDoList: loaded
Compiler: loaded
AStylePlugin: loaded
ClassWizard: loaded
ScriptedWizard: loaded
CodeCompletion: loaded
Abbreviations: loaded
FilesExtensionHandler: loaded
Debugger plugin activated
Open files list plugin activated
OccurrencesHighlighting plugin activated
Foreign projects importer plugin activated
Autosave plugin activated
Todo List plugin activated
Added compiler "GNU GCC Compiler"
Added compiler "Intel C/C++ Compiler"
Added compiler "GDC D Compiler"
Added compiler "GNU Fortran Compiler"
Added compiler "G95 Fortran Compiler"
Added compiler "GNU GCC Compiler for ARM"
Added compiler "GNU GCC Compiler for TriCore (HighTec)"
Added compiler "GNU GCC Compiler for PowerPC (HighTec)"
Added compiler "PGI Fortran Compiler"
Added compiler "Tiny C Compiler"
Added compiler "LLVM D Compiler"
Added compiler "Digital Mars D Compiler"
Added compiler "*No Compiler*"
Added compiler "LLVM Clang Compiler"
Added compiler "GNU GCC Compiler for LM8"
Added compiler "GNU GCC Compiler for LM32"
Added compiler "GNU GCC Compiler for ZPU"
Added compiler "Small Device C Compiler"
Added compiler "GNU GCC Compiler for MSP430 (HighTec)"
Added compiler "GNU GCC Compiler for AVR"
Added compiler "GNU GCC Compiler for Blackfin"
Compiler plugin activated
Source code formatter (AStyle) plugin activated
Class wizard plugin activated
Project wizard added for 'Empty project'
Project wizard added for 'Fortran application'
Project wizard added for 'Fortran library'
Project wizard added for 'Fortran DLL'
Project wizard added for 'Console application'
Project wizard added for 'D application'
Project wizard added for 'FLTK project'
Project wizard added for 'GLFW project'
Project wizard added for 'GLUT project'
Project wizard added for 'GTK+ project'
Project wizard added for 'Irrlicht project'
Project wizard added for 'Lightfeather project'
Project wizard added for 'Matlab project'
Project wizard added for 'OpenCV project'
Project wizard added for 'OpenGL project'
Project wizard added for 'Ogre project'
Project wizard added for 'Code::Blocks plugin'
Project wizard added for 'QT4 project'
Project wizard added for 'SDL project'
Project wizard added for 'SFML project'
Project wizard added for 'Static library'
Project wizard added for 'Shared library'
Project wizard added for 'wxWidgets project'
Build-target wizard added for 'Console'
Build-target wizard added for 'Static library'
Build-target wizard added for 'wxWidgets'
Project wizard added for 'ARM Project'
Project wizard added for 'AVR Project'
Project wizard added for 'TriCore Project'
Project wizard added for 'PowerPC Project'
Project wizard added for 'MCS51 Project'
File(s) wizard added for 'Empty file'
File(s) wizard added for 'C/C++ source'
File(s) wizard added for 'C/C++ header'
File(s) wizard added for 'Fortran source'
Scripted wizard plugin activated
Code completion plugin activated
Abbreviations plugin activated
Files extension handler plugin activated
Loading toolbar...
ClassBrowser::UpdateClassBrowserView(): No active project available.
ClassBrowser::OnThreadEvent(): Updating class browser...
ClassBrowser::OnThreadEvent(): Class browser updated.
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_BODY_BGCOLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_TEXT_COLOUR'
22:15:31: Debug: wxColour::Set - couldn't set to colour string 'CB_LINK_COLOUR'
Initializing plugins...


Can anyone help me out?

Thanks in advance!

« Last Edit: June 12, 2016, 04:22:30 am by chao.mazda »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12081
    • Travis build status
Re: C::B launch problem
« Reply #1 on: June 12, 2016, 09:36:40 pm »
There is nothing in the log that could help us.

Do you have a codeblocks that is installed with the package manager?
Have you tried to recompile?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline chao.mazda

  • Single posting newcomer
  • *
  • Posts: 3
Re: C::B launch problem
« Reply #2 on: June 13, 2016, 04:07:11 am »
Thank you for the reply. I tried to recompile and reinstall, nothing can help. My Debian Jessie was running on Virtual Box. I am planning to try it on a physical PC.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12081
    • Travis build status
Re: C::B launch problem
« Reply #3 on: June 13, 2016, 09:03:18 am »
Do you see some error?
What happens if you use gdb /path/to/codeblocks (this should be the executable)?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]