User forums > Help

Graphical interface issue on Ubuntu Xenial

(1/5) > >>

Mpons:
Hi,

I have recently upgraded my ubuntu distribution from 14.04 to 16.04 and reinstalled code::blocks with the solution proposed here: http://forums.codeblocks.org/index.php/topic,21130.msg144325.html#msg144325. I am now having real troubble with the graphical interface, it appears that after some time things don't get refreshed properly, my tabs freeze but I can still navigate to some extent (if I click on the right spot, i'll see the right tab in my editor but the view of the tabs themselves won't change, if I close a tab I won't see it but it probably disapear from the tab list even though it looks frozen). If I want to open a parameter window (eg Settings/Compiler) I'll just get the frame of the window and it won't close even if I click the cross, my option then is to kill the codeblocks process.
I also tried the version in Ubuntu repos but I have the same issues.

I was wondering if people had the same problems I am having and if somebody could help me figure where it could be coming from. I'm working with codeblocks all day and it's a real hassle having to restart it every fifteen minutes or so.

I hope my description makes sense, i'm sorry if it doesn't. Thanks for your help.
Best,
pons.

stahta01:
Try disabling all the CB Plugins except for the Compiler Plugin.
If the problem goes away, then a CB Plugin is likely the cause.
I would then enable a single plugin at a time and see if you can figure out which one is the cause of the issue.

Tim S.

Mpons:
I tried your suggestion with a lot of hope and conconviction, I even disabled the compiler but I still got the same problem. Am I really the only one with this problem?

wtelam:
I am having the exact same problem.  I just joined this forum to see if I could find a way to fix it.  It appeared suddenly about 2 weeks ago, with Code::Blocks 13.12, which I have used for several months and really like a lot (under Ubuntu 14.04 LTS).  I have tried many uninstalls and reinstalls, purges, as well as manually deleting .codeblocks and all my project files, and installs via apt-get, the Ubuntu software center, and DMoore's PPA.  I finally resorted to formatting the hard drive and doing a new installation of Ubuntu (now 16.04 Xenial Xerus) then installing Code::Blocks fresh via the Ubuntu Software Center.  I did not see any dependency issues.  Same problem immediately reappeared.  I tried disabling all plugins except the Compiler, but no luck.  CB crashed when I opened the plugins dialog to check them.

I can easily reproduce it by starting a new project (Console Application in C++), opening main.cpp, then hiding and showing the editor tabs.  The tabs disappear and some lines from the code appear in their place when they are shown.  The same is true for hiding and showing the status bar.  After this, most of the menu items that show a dialog box will have the box come up blank and the program crashes and must be ended via the System Monitor.

I have attached a screen shot of the new project after the editor tabs and status bar are hidden then shown.  I am using a Dell THX with Ubuntu 16.04, freshly installed.  I have also attached a screenshot of my system about box.

I hope there is a simple fix for this.  It behaves like more WX version problems but I can't gt rid of it with a clean install, which is disconcerting.

dmoore:

--- Quote from: Mpons on May 02, 2016, 06:28:10 pm ---Hi,

I have recently upgraded my ubuntu distribution from 14.04 to 16.04 and reinstalled code::blocks with the solution proposed here: http://forums.codeblocks.org/index.php/topic,21130.msg144325.html#msg144325. I am now having real troubble with the graphical interface, it appears that after some time things don't get refreshed properly, my tabs freeze but I can still navigate to some extent (if I click on the right spot, i'll see the right tab in my editor but the view of the tabs themselves won't change, if I close a tab I won't see it but it probably disapear from the tab list even though it looks frozen). If I want to open a parameter window (eg Settings/Compiler) I'll just get the frame of the window and it won't close even if I click the cross, my option then is to kill the codeblocks process.
I also tried the version in Ubuntu repos but I have the same issues.

I was wondering if people had the same problems I am having and if somebody could help me figure where it could be coming from. I'm working with codeblocks all day and it's a real hassle having to restart it every fifteen minutes or so.

I hope my description makes sense, i'm sorry if it doesn't. Thanks for your help.
Best,
pons.

--- End quote ---

Are you using the PPA with the 16.01 release (codeblocks-stable) or the daily build PPA (codeblocks)? The daily build uses wx3.0 which is probably less stable. Try the codeblocks-stable PPA instead. (Or conversely, try the other way if you are using codeblocks-stable)

Navigation

[0] Message Index

[#] Next page

Go to full version