Author Topic: dependency problems - installation codeblocks 16:01 - ubuntu 16.04  (Read 6644 times)

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1575
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #15 on: April 28, 2016, 02:34:20 am »

I have the same problem, I can not even install the library individually, and this is considering that my installation of Ubuntu 16.04 is fresh.
Ubuntu has dropped libwxbase2.8-0??

Yup. I'm going to upgrade to 16.04 and see if I can fix the problem with the PPA.

Offline Gabriel.LP.Abreu

  • Single posting newcomer
  • *
  • Posts: 5
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #16 on: April 28, 2016, 04:02:13 am »

Yup. I'm going to upgrade to 16.04 and see if I can fix the problem with the PPA.

thank you Damien, i appreciate the help.
I do not know if this information helps, but the site "packages.ubuntu.com" does not list libwxbase2.8-0 as available in Xenial, as you can see here

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1575
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #17 on: April 28, 2016, 04:30:43 am »
Try again.

Offline Gabriel.LP.Abreu

  • Single posting newcomer
  • *
  • Posts: 5
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #18 on: April 28, 2016, 05:43:22 am »
Try again.

is alive!! It is working hahahaha, Successfully installed and tested, perhaps the topic may already be marked as solved.
Now I go back to the studies, thank you! How do you fixed it?

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1575
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #19 on: April 28, 2016, 06:41:01 am »
I had the wrong version string for the wxWidgets build that I put in the PPA. Longer version here: http://askubuntu.com/questions/763754/launchpad-build-recipes-how-do-i-correctly-specify-build-dependencies-for-packa

Offline Gabriel.LP.Abreu

  • Single posting newcomer
  • *
  • Posts: 5
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #20 on: April 28, 2016, 06:58:49 am »
I had the wrong version string for the wxWidgets build that I put in the PPA. Longer version here: http://askubuntu.com/questions/763754/launchpad-build-recipes-how-do-i-correctly-specify-build-dependencies-for-packa

I was just reading this post and the bug report few seconds before returning to the forum and read your answer. Although I do not have much knowledge about it I could understand the problem. Probably this will help others who depend on the same package to resolve the dependency problems in 16.04.

and again thanks a lot! And sorry for bad english.

Offline Gabriele74

  • Single posting newcomer
  • *
  • Posts: 2
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #21 on: April 30, 2016, 06:43:16 pm »
Still not working for me on Ubuntu 64 bit 16.04:

$ sudo apt-get install codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks : Depends: libcodeblocks0 (= 16.01~ubuntu16.04.1) but 16.01 is to be installed
              Depends: codeblocks-common (= 16.01~ubuntu16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Could it be something with my configuration? What can I do to help debug the problem?
Thanks in advance.

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1575
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #22 on: April 30, 2016, 10:41:43 pm »
Still not working for me on Ubuntu 64 bit 16.04:

$ sudo apt-get install codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks : Depends: libcodeblocks0 (= 16.01~ubuntu16.04.1) but 16.01 is to be installed
              Depends: codeblocks-common (= 16.01~ubuntu16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Could it be something with my configuration? What can I do to help debug the problem?
Thanks in advance.

Try apt-get removing codeblocks and wxwidgets and try again.

Offline Gabriele74

  • Single posting newcomer
  • *
  • Posts: 2
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #23 on: May 02, 2016, 10:24:33 am »
Quote
Try apt-get removing codeblocks and wxwidgets and try again.

Thanks a lot, that was it: I had some old codeblocks libraries which were not remove by apt-get --purge autoremove
Manually removing all codeblocks related libraries and doing apt-get install codeblocks solved the issue.

Thanks again  ;D

Offline LETARTARE

  • Regular
  • ***
  • Posts: 337
  • L'ami de l'homme.The friend of man.
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #24 on: October 29, 2017, 11:18:00 am »
Hello,
I started with Linux; I chose 'Kubuntu-16.04-LTS-amd64 (xenial)' because you offer a package for 'wxwidgets2.8'.
Could you provide the gcc version to compile me 'wxwidgets2.8' because I used gcc-4.7 (with CodeBlocks-svn11210)  and is inconsistent?.

Thank you for this excellent work : this is the only version for ubuntu.
« Last Edit: October 29, 2017, 11:35:24 am by LETARTARE »
C::B  : svn11210, 16.01  wxwidgets2.8,
1-Vista Business Pack 2:  TDM-GCC 4.7.1,   CB plugins : QtPregenForCB-0.9,
2-Kubuntu-16.04-LTS-amd64 (xenial) :  g++-5.4.0,
=> !! The messages are translated by GOOGLE !!

Offline LETARTARE

  • Regular
  • ***
  • Posts: 337
  • L'ami de l'homme.The friend of man.
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #25 on: October 30, 2017, 01:29:29 pm »
@dmoore
I finally found the version -> g ++ - 5.4.0
Construction of CB-svn-11210 is correct and the contrib plugins.

Are you planning to provide 'wxWidgets-2.8' for 'Ubuntu-17.04 (zesty) and 17.10 (artful) ?
« Last Edit: October 30, 2017, 01:31:14 pm by LETARTARE »
C::B  : svn11210, 16.01  wxwidgets2.8,
1-Vista Business Pack 2:  TDM-GCC 4.7.1,   CB plugins : QtPregenForCB-0.9,
2-Kubuntu-16.04-LTS-amd64 (xenial) :  g++-5.4.0,
=> !! The messages are translated by GOOGLE !!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10356
Re: dependency problems - installation codeblocks 16:01 - ubuntu 16.04
« Reply #26 on: October 30, 2017, 08:37:02 pm »
I don't think it is a good idea for someone to bother with wx28 builds on ubuntu/debian. We should provide wx3x builds and try to fix as many issues as we can. C::B should be usable already on ubuntu.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]