Author Topic: wxWidgets don't work  (Read 8674 times)

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2337
Re: wxWidgets don't work
« Reply #30 on: April 15, 2016, 11:47:29 pm »
You should be able to edit the wiki (at least before the forum and wiki update it was possible to edit the wiki with the forum user) so you can update the wiki according your way and help other. The whole codeblocks project is made by volunteers and  all do their best, but there are to few people and they have not enough time to update the wiki every time something changes. This is for sure a grievance, but time is precious nowadays, and for my part i spend a lot here in the forum to help people...


Quote
c) Is a "static" variation of all this possible/advisable?  For example, to simplify the distribution of apps produced (not sure about licensing implications??).
Yes it is possible... just compile wxWidgets as static and use the static libraries. But the Wizard will not work with wx3.0

Quote
d) Is unicode necessary?  Perhaps a few words on the pros/cons may be helpful.
I don't know your mother-language, or your target language, but not everyone can speak english and so you will need other glyps than the standard aschii and for this you will need unicode. wx3.0 is compiled by default with unicode enabled...