Author Topic: FATAL ERROR : Mismatch between the program and library build versions  (Read 14210 times)

Offline kpone

  • Single posting newcomer
  • *
  • Posts: 5
Hi, sorry for my bad english i'm french ^^

Well, i've installed codeblocks on Ubuntu 15.10 but when i launch it by terminal i've this error :
Code: [Select]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).

How can i fix this ? Thanks for help :)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6489
    • My Best Post
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #1 on: January 26, 2016, 08:16:19 pm »
You need to build Code::Blocks with the same compiler used to build wxWidgets.

If you still have the error after that; you need to post the compilers used to build both.

Tim S.


Hi, sorry for my bad english i'm french ^^

Well, i've installed codeblocks on Ubuntu 15.10 but when i launch it by terminal i've this error :
Code: [Select]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).

How can i fix this ? Thanks for help :)
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline kpone

  • Single posting newcomer
  • *
  • Posts: 5
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #2 on: January 26, 2016, 08:43:17 pm »
The problem is that i can't open codeblocks (i'm a bit lost)  :-\

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9488
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #3 on: January 27, 2016, 07:33:39 am »
The problem is that i can't open codeblocks (i'm a bit lost)  :-\
If you compiled it yourself: Use a nightly. This should work.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline kpone

  • Single posting newcomer
  • *
  • Posts: 5
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #4 on: January 27, 2016, 09:37:36 am »
sorry but i don't know what do i do :( i'm not experimented and i don't understand what did you say :s

I have try follow this tuto : http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_nightly_build_on_Ubuntu
I've installed all the packages, all dependancies with this build (codeblocks-13.12-1_i386.debian.stable.tar.xz) : http://www.codeblocks.org/downloads/binaries

i don't understand why this not work :(

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2300
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #5 on: January 27, 2016, 03:24:35 pm »
i don't understand why this not work :(
You need to build Code::Blocks with the same compiler used to build wxWidgets.

If you want to come quick to your target: https://launchpad.net/~pasgui/+archive/ubuntu/ppa

if you want compile codeblocks by yourself you have to tell use your exact steps how you compiled codeblocks and wxWidgets. Only
I have try follow this tuto
won't help us or you, because we don't know what you have tried, and where your error is...


greetings

[EDIT:]
Now i see, you are trying to install codeblocks from a nightly... You can try the ppa, or you follow this steps:
http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Linux
« Last Edit: January 27, 2016, 03:26:43 pm by BlueHazzard »

Offline kpone

  • Single posting newcomer
  • *
  • Posts: 5
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #6 on: January 28, 2016, 02:36:44 pm »
i have try the 2 and nothing works _ i need it fast because i'm in IT class and i'm forced to use eclipse :( (eclipse so bad for C++)...

You can't tell me how to uninstall all and make an installation with all links (downloads) etc...
I'm sorry to ask this but i understand nothing in the woking of codeblocks and i have 3 school programming project, i don't have time to search 3-4 hours per day to find a solution :s

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2300
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #7 on: January 28, 2016, 02:43:38 pm »
i have try the 2 and nothing works _ i need it fast because i'm in IT class and i'm forced to use eclipse :( (eclipse so bad for C++)...

You can't tell me how to uninstall all and make an installation with all links (downloads) etc...
I'm sorry to ask this but i understand nothing in the woking of codeblocks and i have 3 school programming project, i don't have time to search 3-4 hours per day to find a solution :s
i am willing to help but you have also to do your part...

tell me exactly what you have done...  else i can't help you...

Offline kpone

  • Single posting newcomer
  • *
  • Posts: 5
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #8 on: January 28, 2016, 08:29:15 pm »
i have install many libraries (all on this link : http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Linux )
I have try follow this tuto : http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_nightly_build_on_Ubuntu
I've installed all the packages, all dependancies with this build (codeblocks-13.12-1_i386.debian.stable.tar.xz) : http://www.codeblocks.org/downloads/binaries

But the error is :
Code: [Select]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).

I need to find how to upgrade the compiler of codeblocks from "compiler with C++ ABI 1002" to "compiler with C++ ABI 1009" or downgrade the compiler of the library from "compiler with C++ ABI 1009" to "compiler with C++ ABI 1002".

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2300
Re: FATAL ERROR : Mismatch between the program and library build versions
« Reply #9 on: January 28, 2016, 09:32:40 pm »
so you mixed all possible steps together.... well we possibly we have a pile of trash that we have to clean up...

We can try to install a nightly, or to compile from source...
to install a nightly:
1) go to your synaptic packet manager and deinstall (remove) all things you find under codeblocks and wxWidgets
2) restart and search again in synaptic if you find something with wxWidgets or codeblocks and remove it also *)
3) **) Install the nightly from pasguis ppa: https://launchpad.net/~pasgui/+archive/ubuntu/ppa
3a) Add the repository to your sources by following this steps https://launchpad.net/+help-soyuz/ppa-sources-list.html, but add use the pasgui ppa (it is described here https://launchpad.net/~pasgui/+archive/ubuntu/ppa under Adding this PPA to your system
3b) Install codeblocks nightly by typing in your terminal:
Code: [Select]
sudo apt-get update
sudo apt-get install codeblocks
3ba) or search in your software center for codeblocks and make sure, you have install the nightly (there should somewhere be written that you install a nightly)

Or Compile from source:
1) Follow this steps, and ONLY this steps from TOP to BOTTOM, all steps http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Linux
 this should work...

if you have problems, please post the exact error and the exact steps you have done..

greetings

*) restart is not 100% necessary but it will help...
**) @dev: why are there no ubuntu release deb? Can he use the debian release?