Author Topic: Xcode/105 Licence Required  (Read 1047 times)

rfgilberg

  • Guest
Xcode/105 Licence Required
« on: January 20, 2016, 09:10:07 pm »
I have been using Code::Blocks on a Mac for a few months now. Today when I tried to compile I received the following message:

Agreeing to the Xcode/105 License requires admin privileges, please re-run as root via sudo.

Why did I get it and how to I fix it? What is sudo?

Thank you

I finally found the right person at Apple. Here are the steps to find the xCode agreement and agree to it:

1. In terminal type: sudo xcodebuild -license

2. You should see the (beginning of) the agreement. As instructed hit [space] until you are at the end of the agreement.

3. type "agree" [as instructed]

4. You should now have the necessary privileges,
« Last Edit: January 26, 2016, 06:22:23 pm by rfgilberg »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11939
    • Travis build status
Re: Xcode/105 Licence Required
« Reply #1 on: January 20, 2016, 09:14:04 pm »
Please ask the vendors of your compiler why this is needed and what to do.
We don't support every compile C::B users use.

Probably what you should do is run "sudo clang" in a terminal.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]