Author Topic: Code::Blocks 13:12 wants to find lib_finder.dll  (Read 1227 times)

rovf

  • Guest
Code::Blocks 13:12 wants to find lib_finder.dll
« on: December 14, 2015, 12:16:59 pm »
Whenever I run Code::Blocks on Windows 7, I get an annoying warning, that lib_finder.dll can't be loaded.

Since this occured already immediately after installation, I thought this might be a bug and created a ticket (https://sourceforge.net/p/codeblocks/tickets/263/), which gave rise to some discussion at the Code::Blocks ticketing system, but in the end, the ticket was set to "invalid", and I got the recommendation to ask this issue at the Code::Blocks forum.

Well, and here I am.  Can someone give me a suggestion, what I could do in this case? Please read also the discussion at the aforementioned link, in order to know, what recommendations had been given already.

BTW, in case I should uninstall Code::Blocks and re-install it, what do I have to do to make sure that my settings are not lost?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6612
    • My Best Post
Re: Code::Blocks 13:12 wants to find lib_finder.dll
« Reply #1 on: December 14, 2015, 07:49:46 pm »
Whenever I run Code::Blocks on Windows 7, I get an annoying warning, that lib_finder.dll can't be loaded.
Remember never install Code::Blocks over a prior installation its the common cause for this error.
Making sure the folder it is installing into is empty is a good way to avoid this issue.

Since this occured already immediately after installation, I thought this might be a bug and created a ticket (https://sourceforge.net/p/codeblocks/tickets/263/), which gave rise to some discussion at the Code::Blocks ticketing system, but in the end, the ticket was set to "invalid", and I got the recommendation to ask this issue at the Code::Blocks forum.

Well, and here I am.  Can someone give me a suggestion, what I could do in this case? Please read also the discussion at the aforementioned link, in order to know, what recommendations had been given already.
Uninstalling and reinstalling is the first thing to try.

BTW, in case I should uninstall Code::Blocks and re-install it, what do I have to do to make sure that my settings are not lost?

Nothing, the CB Setting is not touched by uninstalling and re-installing.
Make you the folder you are installing into is empty; the error you got is sometimes caused by installing in a folder with a prior CB install in it.

Tim S.

« Last Edit: December 14, 2015, 07:52:39 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org