User forums > Nightly builds

The 21 November 2015 build (10595) is out.

(1/9) > >>

Get quick announcements through the RSS feed

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks :

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll :

The 21 November 2015 build is out.
  - Windows :
  - Linux :

The current SDK version is : 1.29.0

Resolved Fixed:

* new version of crash handler (exchndl): more resiliency against truncated PE files and log message when loading symbols
* project options manipulator plugin: support replacements of (existing) custom vars, based on patch #253 by bluehazzard
* astyle plugin: fixed saving some options did not work, based on patch #183 by Li Minggang
* astyle update to v2.0.6pre (required due to license change)
* Header Fixup plugin: applied patch #235: Partial STL completion by Morwenn
* applied patch #102 wxSmithPlot plugin fix by wekn eve iknvwnv
* applied patch #147 'Add file(s)' doesn't account for all generated files for all target's compilers by scarphin
* fixed serious bug #249 Custom build commands broken by nonsensical quotes (macros handling)
* assign CRTL+P to the "Print" command by default (why wasn't this the case in the first place?!)
* updated to (wx)scintilla v3.6.2, still no joy...
Regressions/Confirmed/Annoying/Common bugs:

Hello All.
I'm missing the compiler options for the build suite of normal not CPU specific gnu gcc. If I change the compile  for example to a microsoft or borland compiler the option pane is full of check-boxes but once I change back to gnu the pane is empty again. CPU specific gnu compilers are showing the options also.

It is the same, if I try to edit the options not for the project but in the compiler-settings over the settings nenu.

There is a note that I should right click to set-up or edit the compiler options but nothing happens.

This happens with this build of code-blocks but also with older ones (I tested it back until revision 10528) on win 8.1.
I have attached my default.conf

I hope this is just a bug between my ears so thanks for your tips.

Best regards,

Hello again.

 In the meanwhile I have tested it on win 7 and there this problem does not occur.

Best regards,

Windows 7
When CB is runned with privileged rights I can't open source files by drag and drop nor by context menu.
With context menu following message box is showed:

--- Quote ---"Another instance of CB is running..."
--- End quote ---
not occuring when disable UAC.

#2 less annoying
#include<limits> vs #include <limits>
With first case (no whitespace) in editor, in context menu, option Open "filename_of_header.h" is not visible. Also with " ". limits header is only sample, not single case.

Hello again.

After some searching I found the following post,19196.msg131342.html#msg131342.

Thus I searched for the file "options_gcc.xml" and changed its extension from ".xml" to "._xml_". After this change the compiler-options for the gnu-compiler are visible again;

the attached zip-file contains the file "options_gcc.xml".

As "Sagaceil" i have duplicated the compiler configuration in  the compiler-settings to use a DW2 installation of the gnu compiler also. After copiing it I renamed it and changed the executables. I hope you will find some details about in the "default.conf" attached before.

Best regards,


[0] Message Index

[#] Next page

Go to full version