Author Topic: windows 8 can't build debug can't find file  (Read 6426 times)

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
windows 8 can't build debug can't find file
« on: October 09, 2015, 04:07:52 am »
Hi, Like so many I am just starting code blocks, looks what I need. Installed wrote "Hello World" saved.
Looked for file good location, went to build everything fine, hit run debug request file path correct but does not exist I think. Rechecked location okay. Erased , rewrote and build, same result. Default debug selected.
What am I doing wrong? Thanks for your time.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #2 on: October 09, 2015, 07:17:56 am »
Hi staha, I looked into those and didn't find what I needed. I may have stated my problem a bit wrong I believe it gets compiled and says that things are good in the build message but when I do run the debug says  the file may not exist. I then force run the file myself from the command prompt , a massage comes up with a  saying  program non compatible for win 64 call vendor. Quite confusing.
I have win8 , GCC 4.7.1 windows/unicode-32 bit. I did compile and run a example program that was Hello World from some library I think in one of the beginner c examples. I'll keep my nose in the books and try again.

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #3 on: October 09, 2015, 09:04:27 pm »
any help out there? l am probably on my own with this. was able to get some files to work but went to save them and when reopening they had multiple paths I guess. I have a list of the build problems when I went to reopen a saved file

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: windows 8 can't build debug can't find file
« Reply #4 on: October 09, 2015, 09:19:28 pm »
You're seriously depleting your chances to get any help by NOT posting a full build log as stated in the first link stahta provided.

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #5 on: October 12, 2015, 09:17:05 pm »
Okay let me try this . I start new project hello world then go to build get
Target see an invalid compiled; run aborted

Went to settings Global compiler GNU GCC Compiler listedu
Goto toolchain click auto-detect "could not auto detect , use default installation directory? Yes
 Same invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!] notice came up.
Debug says error "need to specify debug program in settings
For MinGW compiler it's gdb.exe
Select gdb
Try again same thing.
Seems path to compiler not downloaded from code blocks maybe
Sorry not being more computer savey but I am just learning. Thanks for your reply.

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #6 on: October 12, 2015, 09:24:31 pm »
Searching the forums turns up many different compiler issues but they don't seem to be from the default driver issue.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
Re: windows 8 can't build debug can't find file
« Reply #7 on: October 12, 2015, 11:17:06 pm »
Step 1. Install an C/C++ Compiler
(Record the location you installed it into.)
Step 2. Tell Code::Blocks where the compiler is located.
http://wiki.codeblocks.org/index.php/Installing_a_supported_compiler#Compiler-neutral_setup_steps

Tim S.

C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #8 on: October 13, 2015, 02:25:58 am »
okay that almost at least i could see that the download failed at a few important areas which resulted in not getting the complier installed. some files made it but the larger ones didn't. this is my older machine with xp my newer one is win8. i saved the download log showing the larger files failing to download. it is pretty long. would you like to see it? it looks like something on the compliers sight gave the failure notice. thank you for your efforts.

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #9 on: October 13, 2015, 04:01:57 am »
tried downloading  quite a few times now with same results the complier files fail about the same time i have 53 giga available so its not storage. the shutdown is from the web. anyone heard of such a thing, thanks again.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
Re: windows 8 can't build debug can't find file
« Reply #10 on: October 13, 2015, 04:26:07 pm »
I suggest learning to use someting other than .doc files inside zip files to report this problem to the website that supports the compiler!
This site supports only the Code::Blocks IDE. It does NOT support any compiler!

Tim S.


C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #11 on: October 13, 2015, 06:02:28 pm »
Thanks Tim, Working at getting it downloaded.

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #12 on: October 13, 2015, 07:13:59 pm »
Hi all, Well after a night of trying i was able to get my complier downloaded and was able to get a feel of the mingw install manager.
I don't think it came through a standard set up though. I do hello world and open the main save it again but when I try to build the logger says can't find file. Looking under main properties I find it's path but looking into the obj folder it is not there so the compiler is looking in another path I guess. Tim I'll go back into the wiki info on this and see if I can figure it out. Moving foward.

Len

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #13 on: October 13, 2015, 08:18:51 pm »
Hi, Still at it. Tried  adding a path for the compiler to find the saved file hello world but it still can't find the file. I use the properties of the main for the path but the compiler has trouble finding its way probably a bad download. Any suggestions?
Thanks for you efforts. Len

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2569
Re: windows 8 can't build debug can't find file
« Reply #14 on: October 13, 2015, 11:31:41 pm »
why can't you use http://sourceforge.net/projects/tdm-gcc/files/TDM-GCC%20Installer/tdm-gcc-5.1.0-3.exe/download
download it, install it, and let c::b auto detect it...

Hi, Still at it. Tried  adding a path for the compiler to find the saved file hello world but it still can't find the file. I use the properties of the main for the path but the compiler has trouble finding its way probably a bad download. Any suggestions?
Thanks for you efforts. Len

i don't get this part:
Quote
to find the saved file hello world but it still can't find the file.
who can't find witch file?
if your compiler is working, then i would suggest:
Read the FAQs http://wiki.codeblocks.org/index.php/FAQ

At least read these ones:
http://wiki.codeblocks.org/index.php/FAQ-Compiling_%28errors%29#Q:_How_do_I_troubleshoot_a_compiler_problem.3F
http://wiki.codeblocks.org/index.php/FAQ-Compiling_%28errors%29#Q:_My_build_fails_in_the_compile.2Flink.2Frun_step_with_a_Permission_denied_error.3F

Tim S.


specially the part with http://wiki.codeblocks.org/index.php/FAQ-Compiling_%28errors%29#Q:_How_do_I_troubleshoot_a_compiler_problem.3F and there how to post a build log. And don't use .zip files, with .doc in it. Simply paste the build log content in code tags (the # symbol in the new post editor from the forum)

greetings

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #15 on: October 14, 2015, 10:30:37 pm »
BlueHazzard, I was finally able to get the compiler downloaded and it is auto-detected but had to use the manual gnc installer. Seemed to have worked but the build log doesn't find it
mingw32-g++.exe -Wall -g -march=i486 -I"C:\Documents and Settings\Len\My Documents\cblearn\hello world" -I"C:\Documents and Settings\Len\My Documents\cblearn\tryagain" -I"C:\Documents and Settings\Len\My Documents\cblearn" -c "C:\Documents and Settings\Len\My Documents\cblearn\tryagain\tryagain.cpp" -o obj\Debug\tryagain\tryagain.o
mingw32-g++.exe: error: CreateProcess: No such file or directory
Process terminated with status 1 (0 minute(s), 0 second(s))
1 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 
Went and did what was suggested in troubleshot compiler problem but still same. I have found the file with explorer myself but the compiler can't. I tried saving as a c and c++ but still same. I'll try the sourceforge.net again but when I tried that way it would always come up about halfway through download with a download unsuccessful. I tried to do as was noted to identify my core system to the compiler also as you see above -march=i486. Thanks so much everyone for your concern. Len

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #16 on: October 15, 2015, 01:36:16 am »
Hi all, I unistalled cb and got another download, I made sure it had the Mingw compiler files but still no luck compiling. I did however got one file to build and had no issues but go to run and doesn't find the file. I'll just keep trying. Len

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: windows 8 can't build debug can't find file
« Reply #17 on: October 15, 2015, 07:43:56 am »
What is the '-march=i486' flag for? What is your architecture?

Can you please try with a project located in a simpler directory, like 'C:\projects\tryagain' or similar and post your build log under code tags ('#' sign in editor).

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #18 on: October 17, 2015, 05:24:18 pm »
Thank you all! I was able to get the program running by uninstalling it a couple times getting my GNC installer redownloading twice and reinstalling. Now time to talk to my computer and learn this wonderful
program. You'll probably hear from me again. Thanks all, Len

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #19 on: October 18, 2015, 03:14:14 am »
Scarphin, I had tried to identify my processor to the compiler which did not work either.  And yes I did make a very simple path for the compiler which had no better effect.  Uninstalling and reinstalling code blocks worked for  few example programs which was great to see but unfortunately my exe files are now failing. The build is fin but the linking has gone astray. This all maybe related to a Hugh loss of data I had incurred during my original download. I lost 5 gig in that short period of time so my computer maybe compromised. I have I very good working parallax copy so I think it maybe tied to the popup window giving full administrator control to code blocks for my download. In just a matter of 20 minutes my linker now has a glitch. Hope I can overcome these hiccups just looking at the layout and use fullness of code blocks really seems so appealing. I being a baby geek find the pulling call of code blocks. Will keep trying all. Len

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2569
Re: windows 8 can't build debug can't find file
« Reply #20 on: October 18, 2015, 05:43:42 pm »
Thank you all! I was able to get the program running by uninstalling it a couple times getting my GNC installer redownloading twice and reinstalling. Now time to talk to my computer and learn this wonderful
program. You'll probably hear from me again. Thanks all, Len
What is "gnc"?

tied to the popup window giving full administrator control to code blocks for my download.
In just a matter of 20 minutes my linker now has a glitch.
why does c::b download files? where do you get your installation file?

It would be easier to help if you post full rebuild logs. All information we need is stored in this log. Only telling us, that you have glitches and corruped files won't help us help you.
OT:  About the corrupt downloads: I think in my last 3 years of Internet usage i never had a corrupt file from downloading, and i used all kind of connections from 56k over ISDN, ADSL and now fiber. How do you (and other) download files? Isn't TCP made for not loosing data? Are you using download manager? Are you checking the md5sums?

greetings

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2569
Re: windows 8 can't build debug can't find file
« Reply #21 on: October 18, 2015, 05:45:51 pm »
What is the '-march=i486' flag for? What is your architecture?
Scarphin, I had tried to identify my processor to the compiler which did not work either.
Don't mess with the compiler settings. And if you do, post the full build log. I bet you are not using a processor with i486 architecture....

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #22 on: October 18, 2015, 07:11:58 pm »
Hi BlueH, The gnc was a typo gnu was to be there. In the compiler install options during the compiler snaffuu to see if I could direct the install better there is a option to identity the OS system core and that seemed the closest. Now that seems to work, although you maybe right I might remove it but it is working. I'll try to give you the best update on how my install is functioning. I'm using my tablet at a Starbucks now, no airtime left sense that Hugh loss I had during my first install. Okay uninstalled the last code block copy. Still have my GNU Installer on desktop. Reinstalled a fresh copy of code blocks while at this Starbucks. Went through a couple hello world demo writes worked great saved everything from file drop down before leaving. Went to my shop stayed off line and started to open up my first workspace and hello world. Now went to build, just fine, went to run and had the exe. failed. I spent sometime tracing it down found the .o file was located next to the main.c file which was not in the bin file. I think the compiler is working find, tested it on a new project with new main.c and the build was fine. But during the linker phase the .o file is not saved in the obj folder thus the .exe failed statement. I then click on my main.o file, (located next to my main.c file which is not in the
 bin file) and a popup then asks would you like to run cb run console, this maybe a little different I don't have my laptop here, I run the cb console and up comes my program in the command window.
I can modify my hello world then build , all fine, go to run it comes up .exe failed ( I believe linker file not found). Then open up windows explore again, I find the main.o file next to my main.c (not in the
bin file). Click on it, popup says would you like cab console to run file,  yes. Up comes my command
window with the new info added to hello world. I believe when I save file 'hello world' after adding
test words in the program the file is working fine because now the compiler builds correctly from my
source file. Here is where the glitch is the object file does not get saved in the obj folder which I believe is needed for the linker to finish its work. I'll see what data I have left, I paid for extra after that Hugh loss but trying not to have it happen again to me. I'll copy the actual failure message and post it. Thank you for your concern, Len

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2569
Re: windows 8 can't build debug can't find file
« Reply #23 on: October 19, 2015, 02:03:26 pm »
You mess things up somewhere. According your long posts, you are speculating something about (what i can read from your posts) you have 0 plan. You can keep trying to fix this by your on, and trying things out (and i think with this, you will learn a lot) or you can let us help you. But we will need the full build log.

TL:DR:
I, and all others can't help you if you don't post the full build log, so i will not provide any help as long as you won't post the full build log...

greetings and happy hacking

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #24 on: November 02, 2015, 02:42:28 am »
Hi again ,I am stil at it. Redownloaded the program and I can compile and it runs but the command screen
just turns on for a second then turns off. It does have the Hello world printed on it but is off in less then a second.  I have gone into my gnu program folders and the icons that do open the
command prompt show the same response. Feel I'm getting closer now and will continue my efforts.
The build is as follows:

  Building to ensure sources are up-to-date
Selecting target:
Debug
Adding source dir: C:\Users\Len\MDocuments\First Program\
Adding source dir: C:\Users\Len\MDocuments\First Program\
Adding file: C:\Users\Len\MDocuments\First Program\bin\Debug\First Program.exe
Changing directory to: C:/Users/Len/MDOCUM~1/FIRSTP~1/.
Set variable: PATH=.;C:\Program Files (x86)\CodeBlocks\MinGW\bin;C:\Program Files (x86)\CodeBlocks\MinGW;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files\Sony\VAIO Improvement;C:\Program Files (x86)\Sony\VAIO Startup Setting Tool;C:\Program Files (x86)\Microchip\xc16\v1.25\bin;C:\Program Files (x86)\Microchip\xc8\v1.35\bin

[debug]Command-line: C:\Program Files (x86)\CodeBlocks\MINGW\bin\gdb.exe -nx -fullname  -quiet  -args C:/Users/Len/MDOCUM~1/FIRSTP~1/bin/Debug/FIRSTP~1.EXE
[debug]Working dir : C:\Users\Len\MDOCUM~1\FIRSTP~1

Starting debugger: C:\Program Files (x86)\CodeBlocks\MINGW\bin\gdb.exe -nx -fullname  -quiet  -args C:/Users/Len/MDOCUM~1/FIRSTP~1/bin/Debug/FIRSTP~1.EXE
done

[debug]> set prompt >>>>>>cb_gdb:

Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints

[debug]Reading symbols from C:\Users\Len\MDOCUM~1\FIRSTP~1\bin\Debug\FIRSTP~1.EXE...done.
[debug](gdb) >>>>>>cb_gdb:
[debug]> show version
[debug]GNU gdb (GDB) 7.5
[debug]Copyright (C) 2012 Free Software Foundation, Inc.
[debug]License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
[debug]This is free software: you are free to change and redistribute it.
[debug]There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
[debug]and "show warranty" for details.
[debug]This GDB was configured as "i686-pc-mingw32".
[debug]For bug reporting instructions, please see:
[debug]<http://www.gnu.org/software/gdb/bugs/>.
[debug]>>>>>>cb_gdb:
[debug]> set confirm off

Debugger name and version: GNU gdb (GDB) 7.5

[debug]>>>>>>cb_gdb:
[debug]> set width 0
[debug]>>>>>>cb_gdb:
[debug]> set height 0
[debug]>>>>>>cb_gdb:
[debug]> set breakpoint pending on
[debug]>>>>>>cb_gdb:
[debug]> set print asm-demangle on
[debug]>>>>>>cb_gdb:
[debug]> set unwindonsignal on
[debug]>>>>>>cb_gdb:
[debug]> set print elements 0
[debug]>>>>>>cb_gdb:
[debug]> set new-console on
[debug]>>>>>>cb_gdb:
[debug]> set disassembly-flavor att
[debug]>>>>>>cb_gdb:
[debug]> catch throw
[debug]Function "__cxa_throw" not defined.
[debug]Catchpoint 1 (throw)
[debug]>>>>>>cb_gdb:
[debug]> source C:\Program Files (x86)\CodeBlocks\share\codeblocks/scripts/stl-views-1.0.3.gdb
[debug]>>>>>>cb_gdb:
[debug]> directory C:/Users/Len/MDOCUM~1/FIRSTP~1/
[debug]Source directories searched: C:/Users/Len/MDOCUM~1/FIRSTP~1;$cdir;$cwd
[debug]>>>>>>cb_gdb:
[debug]> tbreak "C:/Users/Len/MDocuments/First Program/main.c:4"
[debug]Temporary breakpoint 2 at 0x40136b: file C:\Users\Len\MDocuments\First Program\main.c, line 4.
[debug]>>>>>>cb_gdb:
[debug]> run
[debug]Starting program: C:\Users\Len\MDOCUM~1\FIRSTP~1\bin\Debug\FIRSTP~1.EXE

Child process PID: 10316

[debug][New Thread 10316.0x2888]
[debug]Temporary breakpoint 2, main () at C:\Users\Len\MDocuments\First Program\main.c:6
[debug]C:\Users\Len\MDocuments\First Program\main.c:6:58:beg:0x40136b
[debug]>>>>>>cb_gdb:

At C:\Users\Len\MDocuments\First Program\main.c:6

[debug]> next
[debug]C:\Users\Len\MDocuments\First Program\main.c:7:89:beg:0x401377
[debug]>>>>>>cb_gdb:

At C:\Users\Len\MDocuments\First Program\main.c:7

[debug]> next
[debug]C:\Users\Len\MDocuments\First Program\main.c:8:104:beg:0x40137c
[debug]>>>>>>cb_gdb:

At C:\Users\Len\MDocuments\First Program\main.c:8

[debug]> next
[debug]0x004010fd in __mingw_CRTStartup ()
[debug]>>>>>>cb_gdb:

In __mingw_CRTStartup () ()

[debug]> bt 30
[debug]#0  0x004010fd in __mingw_CRTStartup ()
[debug]#1  0x76660e60 in msvcrt!__setlc_active () from C:\Windows\SysWOW64\msvcrt.dll
[debug]#2  0x777fac69 in ?? ()
[debug]#3  0x777fac3c in ?? ()
[debug]#4  0x00000000 in ?? ()
[debug]>>>>>>cb_gdb:
[debug]> next
[debug]Single stepping until exit from function __mingw_CRTStartup,
[debug]which has no line number information.
[debug]0x0040670c in [email protected] ()
[debug]>>>>>>cb_gdb:

In [email protected] () ()

[debug]> bt 30
[debug]#0  0x0040670c in [email protected] ()
[debug]#1  0x0040110c in __mingw_CRTStartup ()
[debug]#2  0x00000000 in ?? ()
[debug]>>>>>>cb_gdb:
[debug]> next
[debug]Single stepping until exit from function [email protected],
[debug]which has no line number information.
[debug]0x76b839e4 in KERNEL32!GetCurrentApplicationUserModelId () from C:\Windows\SysWOW64\kernel32.dll
[debug]>>>>>>cb_gdb:

In KERNEL32!GetCurrentApplicationUserModelId () (C:\Windows\SysWOW64\kernel32.dll)

[debug]> bt 30
[debug]#0  0x76b839e4 in KERNEL32!GetCurrentApplicationUserModelId () from C:\Windows\SysWOW64\kernel32.dll
[debug]#1  0x0040110c in __mingw_CRTStartup ()
[debug]#2  0x00000000 in ?? ()
[debug]>>>>>>cb_gdb:
[debug]> next
[debug]Single stepping until exit from function KERNEL32!GetCurrentApplicationUserModelId,
[debug]which has no line number information.
[debug]0x7780084a in ?? ()
[debug]>>>>>>cb_gdb:

In ?? () ()

[debug]> bt 30
[debug]#0  0x7780084a in ?? ()
[debug]#1  0x0040110c in __mingw_CRTStartup ()
[debug]#2  0x00000000 in ?? ()
[debug]>>>>>>cb_gdb:
[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function

[debug]> next
[debug]Cannot find bounds of current function
[debug]>>>>>>cb_gdb:

Cannot find bounds of current function
Continuing...

[debug]> cont
[debug]Continuing.
[debug][Inferior 1 (process 10316) exited normally]
[debug]>>>>>>cb_gdb:

[Inferior 1 (process 10316) exited normally]

[debug]> quit

Debugger finished with status 0
                                                                                                                 

Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #25 on: November 02, 2015, 03:04:13 am »
Hi again, I made another attempt at it and both the build and debugger messages cleaned up. still have the flash of the command window the nothing.
 
Checking for existence: C:\Users\Len\MDocuments\okay2\bin\Debug\okay2.exe
Executing: "C:\Users\Len\MDocuments\okay2\bin\Debug\okay2.exe"  (in C:\Users\Len\MDocuments\okay2\.)
Process terminated with status 0 (0 minute(s), 0 second(s))



Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2569
Re: windows 8 can't build debug can't find file
« Reply #26 on: November 02, 2015, 08:05:45 am »
Finally something like a log....
Your program runs fine, but it seems that you are not using the console runner. So if you only print a line and then return from your program it will close fast, because it is finished... You can prevent this behaviour by:
1) Running it trough the cmd
2) add a "cin.get()" at the end

greetings

PS if you have to post a log again, please post it in code tags (the # symbol in the new post editor)


Offline gatolen

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: windows 8 can't build debug can't find file
« Reply #27 on: November 05, 2015, 05:30:35 pm »
Great Bluehazzard, Up and coding, fantastic!!! Great to have help. Making new files under one project
now I'll have to learn the build request it seems I have to uncheck the debug and release on the file I don't want to build to run the new added file. Studying the build process and having fun with this.
Thanks to all advanced geeks out there. Signed geek under training.