Author Topic: Success on MEPIS with a few snags  (Read 3985 times)

-Ilici-

  • Guest
Success on MEPIS with a few snags
« on: March 27, 2005, 06:38:54 pm »
Hi there!

I've managed to get Code::Blocks working on MEPIS (Debian based with KDE). I've installed the libgtk2.0-dev package to compile wxWidgets 2.5. After that I've compiled the code::blocks source with a few problems which i'm not sure how they came to be:

In /plugins/compilergcc, there were errors for an invalid static_cast from wxSpinEvent to a wxCommandEvent. They came in advancedcompileroptionsdlg.cpp and compileroptionsdlg.cpp. The errors were in some functions which responded to a wxSpinControl and were generated in the Event Tables. To fix them iasically i opened the headers for these files and changed the offending function definitions to use a wxSpinEvent instead of wxCommandEvent and then did the same in their implementations (in the cpp files). Also i added #include <wx/spinctrl.h> to the headers for the definitions for wxSpinEvent.

Again I'm not sure if these errros turned out of source bugs or from specifc local causes but if anyone has the same problems, they can fix them.

Other than that everything went ok! Beta6 feels much better than the previous one.

If it would it be possible to get wxWidgets to compile to QT instead of GTK, would Code::Blocks still work?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Success on MEPIS with a few snags
« Reply #1 on: March 27, 2005, 10:08:28 pm »
Quote
If it would it be possible to get wxWidgets to compile to QT instead of GTK, would Code::Blocks still work?

Code::Blocks uses only wxWidgets classes/functions. Which toolkit is used by wxWidgets under the hood, is of no concern whatsoever...

Yiannis.
Be patient!
This bug will be fixed soon...