Author Topic: The 19 June 2015 build (10341) is out.  (Read 29064 times)

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 4906
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 19 June 2015 build (10341) is out.
« Reply #60 on: July 29, 2015, 02:34:36 pm »
i can confirm this...
i noticed it a few revisions before but thought it is a feature for small screens ;)

Thanks, I think this patch should fix this issue:

Code: [Select]
src/sdk/resources/new_from_template.xrc | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/src/sdk/resources/new_from_template.xrc b/src/sdk/resources/new_from_template.xrc
index 3b524f6..b46123f 100644
--- a/src/sdk/resources/new_from_template.xrc
+++ b/src/sdk/resources/new_from_template.xrc
@@ -3,6 +3,7 @@
  <object class="wxScrollingDialog" name="dlgNewFromTemplate">
  <title>New from template</title>
  <centered>1</centered>
+ <style>wxDEFAULT_DIALOG_STYLE|wxRESIZE_BORDER</style>
  <object class="wxFlexGridSizer">
  <cols>2</cols>
  <rows>2</rows>
@@ -196,14 +197,14 @@
  <object class="wxStaticText" name="ID_STATICTEXT6">
  <label>* To delete a user template, delete the similarly named folder created&#x0A;   in %APPDATA%\\codeblocks\\UserTemplates (for Windows) or&#x0A;   ~/Library/Application Support/CodeBlocks (for Mac OS X) or&#x0A;   ~/.config/codeblocks (for other platforms).</label>
  </object>
- <flag></flag>
+ <flag>wxALIGN_NOT</flag>
  </object>
  <object class="sizeritem">
  <object class="wxStaticText" name="ID_STATICTEXT7">
  <label>   Please note the dot (.) in front of &quot;codeblocks&quot;!</label>
  <fg>#800000</fg>
  </object>
- <flag></flag>
+ <flag>wxALIGN_NOT</flag>
  </object>
  </object>
  </object>
I don't know whether we need the second hunk of this patch, because wxsmith automatically add them. :(
I think it is the change in rev10260 which cause the regression.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1349
Re: The 19 June 2015 build (10341) is out.
« Reply #61 on: July 29, 2015, 05:40:45 pm »
i have applied the patch and now it works, but i get the error message:
Code: [Select]
Unknows Style Flag wxALIGN_NOT

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7164
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 19 June 2015 build (10341) is out.
« Reply #62 on: July 29, 2015, 06:48:38 pm »
i have applied the patch and now it works, but i get the error message:
Code: [Select]
Unknows Style Flag wxALIGN_NOT
Did you apply the patch or did you use wxSmith ?
I get the same afte adding the resize-border-flag with wxSmith, the funny thing is wxALIGN_NOT is defined in defs.h of wxWidgets.
I try to investigate further.
Do you get the message always or only if you run C::B with -v parameter ?

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1349
Re: The 19 June 2015 build (10341) is out.
« Reply #63 on: July 29, 2015, 07:28:52 pm »
i only have applied the patch (not on trunk but on r10356 )

i get also the following error:
Code: [Select]
resource file must have same version number!
on startup and following error if i create a new project:
Code: [Select]
Unknows Style Flag wxALIGN_NOT

without "--verbose" i get no errors

greetings

Online stahta01

  • Lives here!
  • ****
  • Posts: 5805
    • My Best Post
Re: The 19 June 2015 build (10341) is out.
« Reply #64 on: July 29, 2015, 07:30:15 pm »
i have applied the patch and now it works, but i get the error message:
Code: [Select]
Unknows Style Flag wxALIGN_NOT
Did you apply the patch or did you use wxSmith ?
I get the same afte adding the resize-border-flag with wxSmith, the funny thing is wxALIGN_NOT is defined in defs.h of wxWidgets.
I try to investigate further.
Do you get the message always or only if you run C::B with -v parameter ?

Edit: This is a wild guess based on seeing something like this error long ago when doing PCH fixes.

Try editing newfromtemplatedlg.cpp by adding "#include <wx/defs.h>"
Before
Code: [Select]
#include "sdk_precomp.h"

#ifndef CB_PRECOMP
    #include <wx/button.h>
after
Code: [Select]
#include "sdk_precomp.h"

#ifndef CB_PRECOMP
    #include <wx/defs.h>
    #include <wx/button.h>
« Last Edit: July 29, 2015, 07:32:33 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 4906
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 19 June 2015 build (10341) is out.
« Reply #65 on: August 06, 2015, 08:05:16 am »
Add the "<style>wxDEFAULT_DIALOG_STYLE|wxRESIZE_BORDER</style>" to the xrc file don't solve the full issue.

If I revert the "new_from_template.xrc" to the revision before the commit rev10260(- core: alignment fixes to avoid asserts and broken layout with wx3), I get a size fixed dialog which is much bigger than the one I mentioned in the post: Re: The 19 June 2015 build (10341) is out..

Suggest:
1, a dialog have the resize feature is quite good than a fixed dialog, so we should add "wxRESIZE_BORDER" to the xrc
2, I initial size of the dialog should be larger(like the same size before the rev 10260)

If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 4906
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 19 June 2015 build (10341) is out.
« Reply #66 on: August 06, 2015, 09:13:33 am »
I think I have found the reason, I see in the old revision, there is a minimal size of the first item of the wxFlexGridSizer.

Code: [Select]
<minsize>480,320</minsize>

And in the commit rev10260, it was removed.

BTW: I'm not sure why in the newer revision as the image in Re: The 19 June 2015 build (10341) is out., the text "Large icons"(bottom right of the dialog) is not shown correctly.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10019
Re: The 19 June 2015 build (10341) is out.
« Reply #67 on: August 06, 2015, 09:18:12 am »
Probably it is removed but mistake, because wxsmith doesn't add it automatically. (this is just a guess)
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5000
Re: The 19 June 2015 build (10341) is out.
« Reply #68 on: August 09, 2015, 10:40:24 am »
I have noticed this too with this dialog, I remember that once it popped up, and nearly all was on 1 line, and I had to scroll big time to the right ;-)

By the way, related maybe, yet another dialog no longer ok : http://forums.codeblocks.org/index.php/topic,20491.msg139414.html#msg139414

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10019
Re: The 19 June 2015 build (10341) is out.
« Reply #69 on: August 12, 2015, 09:52:39 am »
at least since 10341 and also with the latest 10356 I get the following assertion when I mark a variable and try to use following item of the context menu (right mouse click): Find occurences of: 'name':

It should be fixed in svn trunk, please re-test.


the dev-cpp project importer is bugged and will make paths like "..\..\foo.cpp" even on linux where ..\ is invalid and should be ../../ ~

Can you report this in the issues tracker, so it won't get lost?
Please post a bit more detailed steps to reproduce it.

every time i try to delete a Build Target, i get an (seemingly) unlimited loop of assertion errors like this...

This should be fixed in svn-trunk, please test again and report any more problems with it.

Thanks both of you for reporting these issues.
If you see more similar issues don't hesitate to report them.
<debugger plugin maintainer>
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 4906
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 19 June 2015 build (10341) is out.
« Reply #70 on: August 18, 2015, 01:30:26 am »
I found the reason about the warning of wxALIGN_NOT, let's discuss this issue in a separate thread, see my post Re: size of "add include path dialog"
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.