Author Topic: The 19 June 2015 build (10341) is out.  (Read 30889 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5014
The 19 June 2015 build (10341) is out.
« on: June 20, 2015, 04:50:41 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/wxmsw28u_gcc_cb_wx2812_gcc492-TDM.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/mingwm10_gcc492-TDM.7z

The 19 June 2015 build is out.
  - Windows :
   http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/2015/CB_20150619_rev10341_win32.7z
  - Linux :
   none

The current SDK version is : 1.25.0

Resolved Fixed:

  • CC: fix SF ticket 41 CC can`t parse defines with Doxygen single-line comment
  • script_plugin: Fix creating multiple menus from a script plugin
  • fix for pch-creation with gcc 5.x
  • BrowseTracker-plugin: "make dist"-fix; missing images iand xrc-file
  • CC: SF ticket 175, solve typedef declarations in class templates.
  • Fix bug in wxSmith, see http://forums.codeblocks.org/index.php/topic,20338.msg138489.html#msg138489
  • EnvVar: Make the fix from r10309 be conditionally compiled only for non wxMSW2.8 builds(thanks stahta01)
  • CC: apply #178 patch for element access functions belonging to STL containers.

Regressions/Confirmed/Annoying/Common bugs:



    Offline jens

    • Administrator
    • Lives here!
    • *****
    • Posts: 7207
      • Jens' unofficial debian-repository for the Code::Blocks - IDE
    Re: The 19 June 2015 build (10341) is out.
    « Reply #1 on: June 20, 2015, 05:08:11 pm »
    Debian packages (binaries and sources) for 32-bit and 64-bit systems can be found in my debian-repo.
    These packages are build against wxWidgets 3.0 from Debian repos and mght not be as stable than the versions build against wx2.8, but there are no wx2.8 packages available (at least for stable) from official repos.
    Please test and give feedback.

    Currently compiling, will soon be uploaded.

    Fedora packages (binaries and sources) for 32-bit and 64-bit systems (fc20, fc21, fc22 and rawhide), RedHat/CentOS 5 and 6 packages (also 32-bit and 64-bit) and RedHat/CentOS 7 packages (only 64-bit at the moment) can be found in my rpm-repo.
    I recently switched to copr to build and host my Fedora and CentOS packages.
    Instructions how to use it can be found on my server (easier) or on copr (a little more handwork needed).

    Packages for ppc64le are also available on copr for Fedora 21, 22 and Rawhide (not tested).

    Offline shurick

    • Multiple posting newcomer
    • *
    • Posts: 35
    Re: The 19 June 2015 build (10341) is out.
    « Reply #2 on: June 21, 2015, 03:55:44 pm »
    Packages for openSUSE (binaries and sources) for 32-bit and 64-bit.
    Packages for openSUSE http://codeblocks.esy.es  (binaries and sources) for 32-bit and 64-bit.

    ToApolytoXaos

    • Guest
    Re: The 19 June 2015 build (10341) is out.
    « Reply #3 on: June 21, 2015, 04:40:07 pm »
    I have been facing this issue with 103xx revisions.

    It seems hotkeys don't toggle, like F2 or Shift+F2; they just close "Logs & others" and "Management" but don't bring it back.

    This is under GNU / Linux Debian testing 64-bit with gcc (Debian 4.9.2-16) 4.9.2.

    Can anyone confirm this?

    Offline raynebc

    • Almost regular
    • **
    • Posts: 135
    Re: The 19 June 2015 build (10341) is out.
    « Reply #4 on: June 21, 2015, 04:41:50 pm »
    I use the F2 hotkey a lot.  In every nightly I've used (including this latest one) in Windows, that hotkey has worked for me.

    ToApolytoXaos

    • Guest
    Re: The 19 June 2015 build (10341) is out.
    « Reply #5 on: June 21, 2015, 04:50:47 pm »
    Yes, you are correct; it must be a MATE issue or something. I have double-checked it with Fluxbox and work as expected.

    Offline stahta01

    • Lives here!
    • ****
    • Posts: 5938
      • My Best Post
    Re: The 19 June 2015 build (10341) is out.
    « Reply #6 on: June 21, 2015, 05:22:09 pm »
    It works for me.
    svn build rev 10329 (2015-06-11 22:33:15) gcc 4.9.2 Linux/unicode - 64 bit
    wxWidgets 3.0
    From  jens repository

    Debian "Jessie" 8.1 using Mate desktop.

    I only have these CB Plugins enabled
    Compiler,
    Debugger
    Environment variables
    Foreign projects importer
    Project options manipulator
    Scripted wizard
    wxSmith

    Note: I would try turning off keybinder first to see if the problem goes away.


    I have been facing this issue with 103xx revisions.

    It seems hotkeys don't toggle, like F2 or Shift+F2; they just close "Logs & others" and "Management" but don't bring it back.

    This is under GNU / Linux Debian testing 64-bit with gcc (Debian 4.9.2-16) 4.9.2.

    Can anyone confirm this?
    « Last Edit: June 21, 2015, 05:25:40 pm by stahta01 »
    C Programmer working to learn more about C++ and Git.
    On Windows 7 64 bit and Windows 10 32 bit.
    On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
    --
    When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

    ToApolytoXaos

    • Guest
    Re: The 19 June 2015 build (10341) is out.
    « Reply #7 on: June 21, 2015, 05:24:58 pm »
    Note: I would try turning off keybinder first to see if the problem goes away.
    Thank you stahta01. That was indeed the problem. What's the use of this plugin anyway?

    Offline stahta01

    • Lives here!
    • ****
    • Posts: 5938
      • My Best Post
    Re: The 19 June 2015 build (10341) is out.
    « Reply #8 on: June 21, 2015, 05:26:54 pm »
    Note: I would try turning off keybinder first to see if the problem goes away.
    Thank you stahta01. That was indeed the problem. What's the use of this plugin anyway?

    It changes the keybinding to something other than the normal.
    I have never used it, myself.

    Tim S.
    C Programmer working to learn more about C++ and Git.
    On Windows 7 64 bit and Windows 10 32 bit.
    On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
    --
    When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

    Offline scarphin

    • Lives here!
    • ****
    • Posts: 644
    Re: The 19 June 2015 build (10341) is out.
    « Reply #9 on: June 21, 2015, 05:51:52 pm »
    Keybinder doesn't work correctly most of the time. It changes some of the shortcuts back to default sometimes, doesn't work with events configured with bind() or connect() (can anyone associate a shortcut with any of the debug windows?) and I've seen it corrupt the shortcut config file (cbkeybindings or something) in user folder. One of the most buggy plugins in CB imo. I change the defaults or assign new ones from the source code on my local copy to deal with those problems which are otherwise unbearable.

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 10269
    Re: The 19 June 2015 build (10341) is out.
    « Reply #10 on: June 21, 2015, 06:28:36 pm »
    Do you have any steps that can be used to reproduce the problem?

    Keep in mind that if you debug cb from cb it might screw your keybinder settings.
    I don't know why, but I'm sure it can happen.

    On my work machine where I don't debug cb from cb the keybindings are pretty stable.
    <debugger plugin maintainer>
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    ToApolytoXaos

    • Guest
    Re: The 19 June 2015 build (10341) is out.
    « Reply #11 on: June 21, 2015, 06:45:27 pm »
    Do you have any steps that can be used to reproduce the problem?

    Keep in mind that if you debug cb from cb it might screw your keybinder settings.
    I don't know why, but I'm sure it can happen.

    On my work machine where I don't debug cb from cb the keybindings are pretty stable.
    Well, as I I have said, I'm using GNU / Linux Debian testing 64-bit, fully updated using MATE Desktop Environment 1.8.2 and currently compiled svn10341 debian packages with dpkg-buildpackage -us -uc command.

    To reproduce it, just run codeblocks under MATE and as soon as you load a project, press either F2 or shift-F2 while you have keybinder plugin enabled and you will see that it does not toggle at all; it only closes the windows, it does not reopen them.

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 10269
    Re: The 19 June 2015 build (10341) is out.
    « Reply #12 on: June 21, 2015, 06:56:16 pm »
    I'm not talking about this issue:)
    But the one with lost settings.
    <debugger plugin maintainer>
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    ToApolytoXaos

    • Guest
    Re: The 19 June 2015 build (10341) is out.
    « Reply #13 on: June 21, 2015, 07:09:06 pm »
    Eeemm...oops  ;D hahahaha  :P

    Offline scarphin

    • Lives here!
    • ****
    • Posts: 644
    Re: The 19 June 2015 build (10341) is out.
    « Reply #14 on: June 21, 2015, 09:06:43 pm »
    Do you have any steps that can be used to reproduce the problem?
    I'm not able to find what triggers the missing shortcuts, they appear to be random. Steps to reproduce for the unbindable debug windows shortcuts are the same as I described them on my post in 27 October 2014 build (10016) thread:
    svn rev 10020 still exhibits the same problem. Unfortunately I couldn't find a working build after checking all the nightlies I have (back to rev 9673).

    Steps to reproduce:
    1- Launch cb, see the 'debugging windows' bindings are there before loading a project,
    2- Load a project,
    3- Check again to see the bindings are gone.

    Some older revisions doesn't change 'cbkeybinder10.ini' file after closing cb even though the bindings are not listed on the shortcuts dialog, they don't work either. But latest nightlies change the file to add the targets of the opened project.
    The bug is still there as of rev10333 in case someone wants to take a look at it. Apart from those, the help and tools plus plugin entries also exhibit the same behavior. Inspecting the source revealed none of them uses a EVT_MENU entry to link to the actual events (tools plus uses EVT_MENU_RANGE) so I think their linkage methods are the reason for the keybinder plugin to mulfunction.

    Win7 x64