Author Topic: Old links on Mac OS X page.  (Read 2002 times)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6667
    • My Best Post
Old links on Mac OS X page.
« on: June 12, 2015, 03:22:24 am »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Old links on Mac OS X page.
« Reply #1 on: June 20, 2015, 11:53:11 am »
http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Mac_OS_X#Download_the_source_code_2

Many old stuff as in broken links and berlios.de URL usage.

It's a wiki, go edit it. ;-) But seriously, the berlios links and outdated instructions are only half of the problem...
The biggest issue is that wxWidgets on OS X is stuck between 2.8 (10.6/32-bit only) and 3.0 (10.9/64-bit only).

The workaround (for now), will be to run with wxGTK under XQuartz.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12090
    • Travis build status
Re: Old links on Mac OS X page.
« Reply #2 on: June 20, 2015, 12:59:04 pm »
Why should we care about 32bit anymore?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Old links on Mac OS X page.
« Reply #3 on: June 20, 2015, 06:47:58 pm »
Why should we care about 32bit anymore?

The problem is that the wxWidgets 2.8 GUI (wxMac) *only* works in 32-bit, due to Carbon.

So it needs to be updated to wxWidgets 3.0 (wxOSX) that also works in 64-bit, with Cocoa.

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Old links on Mac OS X page.
« Reply #4 on: June 20, 2015, 07:02:44 pm »
Seems that the timing for wxGTK wasn't all the best, as X11 GTK+ support was just removed in Homebrew:

https://github.com/Homebrew/homebrew/pull/39868

This means it (gtk+) cannot be used for wxGTK anymore. Otherwise it was a reasonable workaround for OS X:

https://github.com/afb/homebrew/commit/6bad8b5


So that only leaves wxWidgets 3.0 then, I suppose... I haven't checked how far away that is on trunk, though ?

Doing a custom build of X11 GTK+ just for Code::Blocks is possible of course, if one wants to continue that route.

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Old links on Mac OS X page.
« Reply #5 on: June 21, 2015, 02:16:17 pm »
Seems like wxWidgets 3.0.2 is working just fine, at least for a casual "Hello World" test...
Put both versions up for Homebrew, so that you can compare (but the wxGTK track is dead).

https://github.com/afb/homebrew/tree/codeblocks-gtk (wxGTK, X11)

Code: [Select]
brew install codeblocks
https://github.com/afb/homebrew/tree/codeblocks-osx (wxOSX, Cocoa)

Code: [Select]
brew install --HEAD codeblocks
I had to patch the plugin manager, it was trying to load *.dylib from share/codeblocks directory.
It *should* be loading *.so from lib/codeblocks/plugins dir, just like on any other UNIX really.