Author Topic: SpellChecker plugin  (Read 93277 times)

Offline neo1691

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: SpellChecker plugin
« Reply #120 on: January 14, 2012, 02:54:14 pm »
I am on windows 7 and i dont use mozilla products nor openoffice.

Can anyone share their dictionary or tell me how to use this plugin?

Using latest nightly!

Offline LETARTARE

  • Regular
  • ***
  • Posts: 390
  • L'ami de l'homme.The friend of man.
Re: SpellChecker plugin
« Reply #121 on: January 14, 2012, 03:12:45 pm »
C::B  : svn11831, wx2.8, 3.1.1, plugins : QtPregen-2.6.2-sdk143
1-Vista Business Pack 2 32bits : gcc-8.1.0,
2-OpenSuse-15.1-Leap 64bits :  gcc-7.4.1,
=> !! The messages are translated by Deepl !!

Offline neo1691

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: SpellChecker plugin
« Reply #122 on: January 14, 2012, 03:39:13 pm »

Offline neo1691

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: SpellChecker plugin
« Reply #123 on: January 16, 2012, 02:31:22 pm »
Try :
http://wiki.codeblocks.org/index.php?title=SpellChecker
Quote
Dictionaries->download

Thanks!! :D
Working flawlessly now!

BTW does it just highlights the spell errors or corrects them too?? Cos i am not able to find how to correct my spell errors in strings and comments

Offline danselmi

  • Developer
  • Almost regular
  • *****
  • Posts: 202
Re: SpellChecker plugin
« Reply #124 on: January 16, 2012, 02:39:28 pm »
Have you tried to right click a marked word and checked "Spelling Suggestions for 'wrongword'"?
I will adjust the wiki...

Offline neo1691

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: SpellChecker plugin
« Reply #125 on: January 16, 2012, 02:40:43 pm »
Have you tried to right click a marked word and checked "Spelling Suggestions for 'wrongword'"?
I will adjust the wiki...

Sorry my bad!  :P
Found it!!!

Thanks

Offline ptDev

  • Almost regular
  • **
  • Posts: 222
Re: SpellChecker plugin
« Reply #126 on: March 10, 2012, 08:35:35 pm »
I found a minor cosmetic issue with the SpellChecker plugin that bugged me somewhat, so I made the status bar menu and settings combo box use human-readable language names (i.e., "English (United States)") rather than the abbreviation which is not always clear to the user (i.e., "en_US").

The changes are in the attached patch. You'll notice a very primitive implementation of GetLanguageName(), but I ended up doing it this way, because I couldn't get it to work with neither wxHashMap nor std::map<> for some reason. I did lose patience, but still hope someone else takes the patch and refactors it to a more efficient alternative. For now, you can already get proper language names listed in the user interface using this patch.

EDIT: Fixed a bug in the previously uploaded patch.
« Last Edit: March 10, 2012, 10:20:28 pm by ptDev »

Offline xunxun

  • Almost regular
  • **
  • Posts: 187
Re: SpellChecker plugin
« Reply #127 on: February 15, 2013, 10:21:55 am »
Can you make the plugin support Language Tool :
http://languagetool.org/
http://languagetool.org/languages/

because only languagetool.org has Chinese spell checking.

And it also has Firefox/OpenOffice Add-on.
Regards,
xunxun

Offline chameleon

  • Multiple posting newcomer
  • *
  • Posts: 29
Re: SpellChecker plugin
« Reply #128 on: December 12, 2014, 05:34:14 pm »
Mr Anselmi
Can you please make the SpellChecker support multiple languages?

My point is:
I use my native language for code comments, but comments have a big amount of english keywords.

Thanks for awesome plugin.

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: SpellChecker plugin
« Reply #129 on: March 17, 2015, 04:03:46 pm »
Is it just me or does it NOT compile anymore with:
Code: [Select]
||=== Build: hunspell in SpellChecker (compiler: GNU GCC Compiler x32) ===|
D:\coding\projects\sw\codeblocks\trunk\src\plugins\contrib\SpellChecker\hunspell\src\hunspell\baseaffix.hxx|28|error: 'MAXCONDLEN' was not declared in this scope|
D:\coding\projects\sw\codeblocks\trunk\src\plugins\contrib\SpellChecker\hunspell\src\hunspell\baseaffix.hxx|30|error: 'MAXCONDLEN_1' was not declared in this scope|
||=== Build failed: 2 error(s), 0 warning(s) (0 minute(s), 3 second(s)) ===|
Win7 x64

Offline LETARTARE

  • Regular
  • ***
  • Posts: 390
  • L'ami de l'homme.The friend of man.
Re: SpellChecker plugin
« Reply #130 on: March 17, 2015, 04:26:36 pm »
svn 10127 : compiles correctly
'MAXCONDLEN' is defined in 'atypes.hxx'
C::B  : svn11831, wx2.8, 3.1.1, plugins : QtPregen-2.6.2-sdk143
1-Vista Business Pack 2 32bits : gcc-8.1.0,
2-OpenSuse-15.1-Leap 64bits :  gcc-7.4.1,
=> !! The messages are translated by Deepl !!

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: SpellChecker plugin
« Reply #131 on: March 17, 2015, 05:11:32 pm »
My bad, I messed up the project file. Sorry for the trouble.