Author Topic: Jump via doubleclick from error-log to appropriate position in the sourcecode?  (Read 2353 times)

Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
Hi

I wonder whether that option (look at the topic) is not included yet. Or is there an plugin?
Toodle-oo!

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
I wonder whether that option (look at the topic) is not included yet. Or is there an plugin?
Works fine here, even with a single click from the "Build messages" tab.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
If it still does not work:
which compiler do you use ?
is the output localized ?

Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
If it still does not work:
which compiler do you use ?

Gnu GCC

Quote
is the output localized ?

It seems, I can't localize the program.

I installed

codeblocks-13.12mingw-setup.exe

from

http://www.codeblocks.org/downloads/26

So I work with the defaults.






Toodle-oo!


Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
If gcc is localized, you can try this: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28errors%29#Q:_How_can_I_change_the_language_of_the_compiler_.28gcc.29_output_to_english.3F

I am german. If this is important in that case because of the OS-settings.

After installation the IDE runs in english language. And I cant change that.

I tried what you suggested, but it has no effect. Even the value en_US.utf8 don't work.

I tried also the editor-setting "use encoding when opening files" with "default". (After installation
it was "windows-1252".


Toodle-oo!

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6613
    • My Best Post
What is the language displayed in "Build messages" tab?
The "Build messages" contains the output from the compiler if logging has NOT been disabled.

You may wish to verify full logging is enabled.
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28errors%29#Q:_How_do_I_troubleshoot_a_compiler_problem.3F

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
What is the language displayed in "Build messages" tab?

English, as the whole IDE works in english here.

Quote
The "Build messages" contains the output from the compiler if logging has NOT been disabled.

It is set to "Full command line" and I tested the "build log" and the "build messages". For me
it still don't work No Idea. I simply installed the program, choose the compiler and thats it.

At least the affected line is named, so I can go there "by hand".

But thank you, for trying to help me.



Toodle-oo!

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
In some cases spaces or non english characters can lead to such problems.
If this is the case you should see something weird (cut paths) in the "File"-column of the "Build messages" tab.

Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
Here is the Build-Log:

---------------------------- cut ----------------------------------

||=== Build: Release in DNS_Umschalter (compiler: GNU GCC Compiler) ===|
CodeBlocks_Tests\DNS_Umschalter\DNS_Umschalter\DNS_Umschalter.cpp||In function 'BOOL IsUserAdmin()':|
CodeBlocks_Tests\DNS_Umschalter\DNS_Umschalter\DNS_Umschalter.cpp|591|warning: missing braces around initializer for 'BYTE [6] {aka unsigned char [6]}' [-Wmissing-braces]|
obj\Release\DNS_Umschalter.o:DNS_Umschalter.cpp|| undefined reference to `CheckTokenMembership(void*, void*, int*)@12'|
||=== Build failed: 1 error(s), 1 warning(s) (0 minute(s), 0 second(s)) ===|

---------------------------- cut ----------------------------------



The only thing I see, is that the path seems to be relative. It begins with the project-directory.
Toodle-oo!

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
If I see it correctly (in your other post) the path begins with an exclamation-mark ("!").
Try to remove it !

And please use code-tags (the button with the hash [ # ]) if you post code or log-content.

Offline jmb

  • Multiple posting newcomer
  • *
  • Posts: 21
If I see it correctly (in your other post) the path begins with an exclamation-mark ("!").
Try to remove it !

You've found the reason :-)  Thank you. I removed that char and now it works.

Quote
And please use code-tags (the button with the hash [ # ]) if you post code or log-content.

ok, I thought, I don't need that, because it is simple text without any format.

Toodle-oo!