Author Topic: appearance  (Read 7160 times)

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
appearance
« on: August 30, 2014, 11:38:19 am »
Is it possible to change the width of the column which contains lines of numbers? I have small screen resolution 800x600 and big size of font (13px) and it results in very wide columns. 8-9 digits would fit to the width of the column, even that there are only 2 digit numbers in file which I have opened. It looks strange because area of code starts near the begin of 2nd third of the width of screen (having Management displayed).

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: appearance
« Reply #1 on: August 30, 2014, 02:31:47 pm »
Look into "Settings->Editor->Margins and caret"

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #2 on: August 30, 2014, 08:23:07 pm »
Thanks. And how to set color of cursor (it is not visible when I set black color on highlighting in C/C++ code)?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: appearance
« Reply #3 on: August 30, 2014, 08:49:25 pm »
Are you joking?  :o ::) It is the same place!  ::)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #4 on: August 30, 2014, 09:30:04 pm »
New problem. I disable all tool panels (icons on the top, just bellow menu). But when I build they are shown again. This is very frustrating. I must hide them always again and because they are many, this sucks. How to get rid of them? Taking place on screen.

Check this:
« Last Edit: August 30, 2014, 09:48:18 pm by wever »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: appearance
« Reply #5 on: August 30, 2014, 09:52:16 pm »
Yes, just close all the toolbars... probably start inspecting the View menu...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: appearance
« Reply #6 on: August 30, 2014, 09:54:16 pm »
...not to forget that you can have a "full screen view " with F11 and maximise the editor when working on it by double-clicking on it tab.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #7 on: August 30, 2014, 10:21:13 pm »
Yes, just close all the toolbars... probably start inspecting the View menu...

Seems I found it. I saved the perspective and now the did not disappear.

The F11 key displays dialoq window asking me if I want to create file which does not exists. I am debuging the code. But that's another story.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: appearance
« Reply #8 on: August 30, 2014, 10:32:32 pm »
Fullscreen is engaged by shift-f11 or view -> full screen  ::)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #9 on: August 30, 2014, 10:39:18 pm »
Why does it always display "the perspective blabla has changed, do you want to save it?" This sucks

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re:
« Reply #10 on: August 30, 2014, 10:41:43 pm »
...because you don't enable'"don't annoy me again" :-)
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #11 on: August 30, 2014, 11:20:18 pm »
Oops i did not noticed that sentence

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #12 on: September 05, 2014, 10:53:30 am »
Every time when I press the F8 to debug I see this:



Few times I have saved the perspectives with disabled toolbars and I have checked the Don't annoy me control. But this is still there. I have to use the saved Perspective with Watches window, but even that, the Watches window disappeared. So it does not work to me as I need.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re:
« Reply #13 on: September 05, 2014, 05:56:54 pm »
You can setup multiple perspectives. There is a specific one used for debugging. You cab setup through the debugger options to which to flip. It reverts back to the original perspective once debugging has finished.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #14 on: September 05, 2014, 06:36:16 pm »
Which one is for debugging and where to set it? I don't see such option.

Offline Alpha

  • Developer
  • Lives here!
  • *****
  • Posts: 1513
Re: appearance
« Reply #15 on: September 05, 2014, 07:48:29 pm »
(Sorry, slightly off topic.)  I noticed in your screen shots that the spellchecker is underlining all your strings in red, a problem that I thought was fixed before 13.12 release.  Out of curiosity, could you right click on the flag (bottom right corner) and test several of the options?

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #16 on: September 06, 2014, 12:11:31 am »
Yeah, I have tried both USA and UK language it makes underline English words. But I can disable the spellcheck.

Offline wever

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: appearance
« Reply #17 on: September 07, 2014, 10:25:27 am »
I am still having problems with the look in 13.12.

Then I turn on Watch window using Watch "variable", there is not redraw performed in the client area. I have to move the window over screen to redraw the area and see content. Also every time the columns are too small and I have to drag them to fix the text size to see the values.