Author Topic: Recurrent problem with error 500 on sourceforge  (Read 5525 times)

Offline gd_on

  • Lives here!
  • ****
  • Posts: 558
Recurrent problem with error 500 on sourceforge
« on: May 09, 2014, 03:11:27 pm »
With some svn versions, I have a recurrent problem when I try to access : http://sourceforge.net/p/codeblocks/code/log/ (or http://sourceforge.net/p/codeblocks/code/HEAD/log/)
This link normally shows the last svn, but with some svn versions it does not work as expected : for example the last problems were with svn 9760 and 9763.
I obtain this error : Error 500, We're sorry but we weren't able to process this request.

But when a new svn version appears, for example here 9761, all is OK again.
The strange thing is that when this new version appears, the previous link like : http://sourceforge.net/p/codeblocks/code/9760/log/ works now correctly.
If I try directly http://sourceforge.net/p/codeblocks/code/9763/log/, this time it's an error 400 ! But I think this page exists.

Of course, there is a work around with biplab mirror : http://cb.biplab.in/websvn/log.php

A sourceforge problem ? something bad when some new svn is proposed ?

gd_on
« Last Edit: May 09, 2014, 05:50:18 pm by gd_on »
Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.4 (git), Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32). Tests and switch to msys2 and gcc 9.3 compilers.

Offline Alpha

  • Developer
  • Lives here!
  • *****
  • Posts: 1513
Re: Recurrent problem with error 500 on sourceforge
« Reply #1 on: May 09, 2014, 04:00:00 pm »
I think someone reported this to SourceForge some time ago (but I do not recall what their response was).
From what I know, SourceForge has trouble displaying a log entry/the most recent log entry, if the timestamps between between it and the previous are "too close" (within a minute, or something, probably).  This can happen when using git svn dcommit.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: Recurrent problem with error 500 on sourceforge
« Reply #2 on: May 09, 2014, 09:37:11 pm »
Yes, happens every time I commit something. Report it to sf.net, probably if enough people bother them, they'll try to do something. Last time I tried to talk to them about this they did nothing.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gd_on

  • Lives here!
  • ****
  • Posts: 558
Re: Recurrent problem with error 500 on sourceforge
« Reply #3 on: May 10, 2014, 12:27:03 pm »
No problems with your last commit svn 9764. Maybe because, as told Alpha, it's an alone commit.
Looking at your previous commits where there was problems (9760 and 9763), shows that those commits are separated only by a few seconds from the previous ones (here 9759 and 9762 respectively).
So a suggestion : if you have several commits, try to push the last one, let say 1 or 2 minutes after the other ones.

gd_on
Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.4 (git), Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32). Tests and switch to msys2 and gcc 9.3 compilers.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: Recurrent problem with error 500 on sourceforge
« Reply #4 on: May 10, 2014, 08:49:11 pm »
So a suggestion : if you have several commits, try to push the last one, let say 1 or 2 minutes after the other ones.
Sorry, won't happen... report the problem to sf.net devs if they think it is a serious problem they'll fix it.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]