Author Topic: How make Code:Blocks work with MSP430 on Ubuntu  (Read 8065 times)

Startkran

  • Guest
How make Code:Blocks work with MSP430 on Ubuntu
« on: April 18, 2014, 08:51:18 pm »
I'm new to CB and to IDEs too, guys...
Can anybody help with making CB work with MSP430-FET430UIF and msp430f413.

I'm using ubuntu 12.04.4 and after number of attempts I finally installed CB from ubuntu reps (just
Code: [Select]
sudo apt-get install codeblocks) and I have installed mspdebud (I need it, right?).

Now, as I see, there is no any compiler for msp430.

What compiler I need? Where can I get that compiler? How to install it? How to connect CB and mspdebug? What else I have to do to work with my MCP?

I saw this (http://forums.codeblocks.org/index.php/topic,17728.0.html), but topic is so old! And I have no idea how to install that patches and will they work.

Any help is appreciated!

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6550
    • My Best Post
Re: How make Code:Blocks work with MSP430 on Ubuntu
« Reply #1 on: April 18, 2014, 09:38:27 pm »
Where to get the Compiler should likely be asked on a site supporting the MCU or your operating system.

It is unlikely anyone on this site will know the answer.

Edit: One of the Google results I got http://packages.ubuntu.com/precise/gcc-msp430

Tim S.
« Last Edit: April 18, 2014, 09:59:35 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org