Author Topic: Bookmarks NOT being saved.  (Read 3385 times)

Offline Uname

  • Single posting newcomer
  • *
  • Posts: 2
Bookmarks NOT being saved.
« on: January 02, 2014, 09:30:55 pm »
Hello,

I am able to create bookmarks (i.e. ctrl-b funtionality) for a GTK+ project (using C99 if that matters).  Bookmark functionality works perfectly until the project is closed.  Once it is reopened ALL bookmarks are gone;  no bookmark is saved.  Currently I am using v13.12.

I had a similar problem on v10.05.  The problem on that old version was that sometimes bookmarks are saved, other times they were lost.

Is there anyone who can confirm if this is a bug or not?

--------------
Details:

Code::Blocks 13.12 rev9501
Build:  Dec 30 2013, 01:24:19 - wx2.8.12 (Linux, unicode) - 64 bit
SDK Version:  1.19.0
O/S:  Ubuntu 12.04.3 (64 bit)

Program was installed from Pasgui's PPA.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12002
    • Travis build status
Re: Bookmarks NOT being saved.
« Reply #1 on: January 02, 2014, 09:53:33 pm »
Is there anyone who can confirm if this is a bug or not?
It is not a bug, but missing feature - the default bookmarks are not saved.
Probably you're using the BrowseTracker plugin for some of the bookmarks and I think there is a save/restore feature in this plugin.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Uname

  • Single posting newcomer
  • *
  • Posts: 2
Re: Bookmarks NOT being saved.
« Reply #2 on: January 02, 2014, 10:26:39 pm »
It is not a bug, but missing feature - the default bookmarks are not saved.
Probably you're using the BrowseTracker plugin for some of the bookmarks and I think there is a save/restore feature in this plugin.

You are correct;  I am using Browse Tracker plugin.  According to the code::blocks manual [section 2.8] "The markers are saved in the layout file <projectName>.bmarks".  I'm assuming markers == book marks.

If I open project.bmarks, there is something like:
Code: [Select]
...
<File name="file.c" open="1" top="1" tabpos="12">
<Cursor position="2847" topLine="94" />
<BrowseMarks positions="2474" />
<Book_Marks positions="2661,2371,2371,2658,2847" />
</File>
...

The <Book_Marks> tag is presumably referring to my bookmarks.  Therefore I do believe that the bookmarks are saved, but they are not loaded for some reason...

Please correct me if I'm wrong.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12002
    • Travis build status
Re: Bookmarks NOT being saved.
« Reply #3 on: January 02, 2014, 11:40:04 pm »
Please correct me if I'm wrong.
I can't, I'm not using BrowseTracker. Probably someone else can.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]