Author Topic: 12.11 windows 'user install' - crash on settings  (Read 10286 times)

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2566
Re: 12.11 windows 'user install' - crash on settings
« Reply #15 on: December 06, 2013, 04:30:51 pm »

Offline originalsurfmex

  • Single posting newcomer
  • *
  • Posts: 7
Re: 12.11 windows 'user install' - crash on settings
« Reply #16 on: December 06, 2013, 05:39:41 pm »
BlueHazzard - that is very very cool, thanks.  Here is the output of my crash:

Code: [Select]
codeblocks.exe caused an Integer Divide By Zero at location 66854E88 in module COMCTL32.DLL.

Registers:
eax=00000002 ebx=00731eb0 ecx=0028d360 edx=00000000 esi=006ed940 edi=00000001
eip=66854e88 esp=0028d338 ebp=0028d378 iopl=0         nv up ei pl zr na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246

AddrPC   Params
66854E88 00731DD8 00731EB0 006ED940 COMCTL32.DLL!ImageList_Read
6687DE35 00000003 0028D3E8 0028D3D8 COMCTL32.DLL!DPA_DeleteAllPtrs
6687F27F 0028D3D8 00000000 00000003 COMCTL32.DLL!DPA_Sort
6687F222 00705EC0 66854DDC 006ED940 COMCTL32.DLL!DPA_Sort
6689999F 00000000 0028D594 6687CFE2 COMCTL32.DLL!ImageList_Write
66851EE0 006ED940 00000000 00000000 COMCTL32.DLL!Ordinal175
6687CFE2 004E35B2 00001016 00000000 COMCTL32.DLL!DPA_DeleteAllPtrs
6687FE70 004E35B2 00001016 00000000 COMCTL32.DLL!CCGetScrollInfo
76FC62FA 6687FE38 004E35B2 00001016 USER32.dll!gapfnScSendMessage
76FC6D3A 00000000 6687FE38 004E35B2 USER32.dll!GetThreadDesktop
76FD0D27 6687FE38 004E35B2 00001016 USER32.dll!GetClientRect
76FD0D4D 6687FE38 004E35B2 00001016 USER32.dll!CallWindowProcW

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2566
Re: 12.11 windows 'user install' - crash on settings
« Reply #17 on: December 07, 2013, 12:23:54 am »
Sadly this doesn't help neither without debug symbols...

Have you the possibility to compile c::b for yourself?

If so: Can you pleas compile it with "-g" in global variables "cb_release_type"

i personally have absolute no idea where the error comes from, but probably it is a wxWidgets error (bug), because no other user reported such a heavy bug (until now)..

greetings