Author Topic: Raspberry PI  (Read 10208 times)

tbandtg

  • Guest
Raspberry PI
« on: November 16, 2012, 04:54:01 pm »
I would like to build codeblocks from source to run on the raspberry pi. I have ran and installed all the libtools, gtk+-3, gtk+-2.0 but when I do ./configure it says it can not find gtk+. Has anyone gotten this to work. It is not a big deal. It is just something I wanted to see if i could get it to work.

I am currently on raspian wheezy.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11939
    • Travis build status
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline cacb

  • Regular
  • ***
  • Posts: 392
Re: Raspberry PI
« Reply #2 on: January 04, 2014, 11:45:55 am »
See here:
https://code.google.com/p/codeblocks-on-raspberrypi/downloads/list
and
http://forums.codeblocks.org/index.php/topic,17084.0.html

I just got a Raspberry Pi and have it running with Raspbian. I can see the "codeblocks-on-raspbian" page above has precompiled versions of Code::Blocks for Raspbian, up until svn 9506. Very convenient!

I shall give it a go and see what happens. If anyone have additional pointers that might help...

Offline cacb

  • Regular
  • ***
  • Posts: 392
Re: Raspberry PI
« Reply #3 on: January 11, 2014, 10:39:16 pm »
I just got a Raspberry Pi and have it running with Raspbian. I can see the "codeblocks-on-raspbian" page above has precompiled versions of Code::Blocks for Raspbian, up until svn 9506. Very convenient!

I shall give it a go and see what happens. If anyone have additional pointers that might help...

I now have Code::Blocks svn 9506 running on the Raspberry PI, quite impressive for that little device!

The download from the google.com site is high quality, with excellent scripts for setting things up and installing/removing.