Author Topic: Dependency is not satisfiable: libfontconfig1  (Read 17049 times)

Offline Monochron

  • Single posting newcomer
  • *
  • Posts: 5
Dependency is not satisfiable: libfontconfig1
« on: August 14, 2013, 03:38:04 am »
I found a couple references on here to this failed dependency, but no results that helped me.

I am on Ubunutu 12.04.2 32 bit.

I have been double clicking the various .deb files in the binaries download and often get the error "Failed to satisfy all dependencies (broken cache) in the Software Center.  This seems to happen at random after clicking various .deb files.  Both not-yet-installed and already-installed .deb files cause this, but I am relatively sure that the only two left to be isntalled are codeblocks and codeblock-contrib.

Both of those .deb files say they need libfontconfig1 (>= 2.9.0) which I have already installed.  apt-get gives this message:
libfontconfig1 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have tried "dpkg -i *.deb" in the correct folder but it gave errors on those same two files.

I have tried sudo apt-get install codeblocks to which I get this error:
The following packages have unmet dependencies:
 codeblocks : Depends: codeblocks-common (= 10.05-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Fixing my broken packages does nothing to fix the problem.

Does anyone have a solution to this?  I am really surprised to see an error like on a fresh install of Linux with C::B.

EDIT: Forgot to mention, the only version of libfontconfig1 in the Software Center is 2.8.0.
« Last Edit: August 14, 2013, 05:55:54 am by Monochron »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Dependency is not satisfiable: libfontconfig1
« Reply #1 on: August 14, 2013, 02:01:59 pm »
You can not use the debian files with Ubuntu.
It has moved to far away from debian in the meantime.
That's stated clearly in the forum and also on our website.
Search for Iimportant note for Ubuntu users on http://www.codeblocks.org/downloads/26 .

Offline Monochron

  • Single posting newcomer
  • *
  • Posts: 5
Re: Dependency is not satisfiable: libfontconfig1
« Reply #2 on: August 14, 2013, 09:37:28 pm »
Huh, I was going based off of this forum post where the author seemed to be able to install it:
http://forums.codeblocks.org/index.php?topic=18209.msg124512;topicseen

He used apt-get which still gives me errors...was he maybe using that repository listed on the download page?

Offline Monochron

  • Single posting newcomer
  • *
  • Posts: 5
Re: Dependency is not satisfiable: libfontconfig1
« Reply #3 on: August 15, 2013, 02:49:32 am »
Okay sorry about this, but I am new to using apt-get intensively. I found pasgui's repository but there are no instructions on how to get the packages on my system.  Then I found this page:
http://linuxers.org/howto/how-install-any-software-ubuntu-ppa

But the instruction there have you setup the ppa and then just run apt-get again.  But as pasgui's version of CB has the same name as the normal version I don't see how apt-get would know to grab his and not the normal version.  Trying it produces the same result as before.  Trying the dist-upgrade command has no result whatsoever "0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded."

Surely I am doing something wrong or not seeing the instructions?
Not to be ungrateful . . . but is there anywhere I can just download the package files from? Or even an installer?
I am willing to work for it and learn to use the traditional Linux methods . . . but I guess I am just not very good at it.

Offline Monochron

  • Single posting newcomer
  • *
  • Posts: 5
Re: Dependency is not satisfiable: libfontconfig1
« Reply #4 on: August 15, 2013, 03:13:12 am »
I fixed it.

The solution?  It completely failed the first time, apparently just trying it again will fix it.  As far as I can tell this isn't a problem with CB, it is just a problem with Ubuntu's package system.  One of the reasons I still prefer just downloading an installer from the web like every other desktop OS. 

I figured I should post my shell output just in case anyone reads this in the future and has to have it break a couple times before it finally works. In between these two attempt I did an apt-get clean.  Of course, I never got any indication that I needed to. The most descriptive error I got was that codeblocks had an unmet dependency . . .

--------------------------------------------------------------------------------------------------------------------------------------------------------------

[email protected]:~$ sudo add-apt-repository ppa:pasgui/ppa
You are about to add the following PPA to your system:
 
 More info: https://launchpad.net/~pasgui/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpDXdK1O/secring.gpg' created
gpg: keyring `/tmp/tmpDXdK1O/pubring.gpg' created
gpg: requesting key F599ACE3 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpDXdK1O/trustdb.gpg: trustdb created
gpg: key F599ACE3: public key "Launchpad PPA for pasgui" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo apt-get dist-upgrade
[sudo] password for brian:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo apt-get install codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks : Depends: codeblocks-common (= 10.05-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[email protected]:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

-----------------------------------------------------------------------------------------------------------------------------------------------------------
Followed by:
-----------------------------------------------------------------------------------------------------------------------------------------------------------

[email protected]:~$ sudo add-apt-repository ppa:pasgui/ppa
You are about to add the following PPA to your system:
 
 More info: https://launchpad.net/~pasgui/+archive/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpG3HwB6/secring.gpg' created
gpg: keyring `/tmp/tmpG3HwB6/pubring.gpg' created
gpg: requesting key F599ACE3 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpG3HwB6/trustdb.gpg: trustdb created
gpg: key F599ACE3: public key "Launchpad PPA for pasgui" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
[email protected]:~$ sudo apt-get update
Hit http://us.archive.ubuntu.com precise Release.gpg
Get:1 http://us.archive.ubuntu.com precise-updates Release.gpg [198 B]         
Hit http://us.archive.ubuntu.com precise-backports Release.gpg                 
Hit http://us.archive.ubuntu.com precise Release                               
Get:2 http://us.archive.ubuntu.com precise-updates Release [49.6 kB]           
Hit http://security.ubuntu.com precise-security Release.gpg                   
Get:3 http://extras.ubuntu.com precise Release.gpg [72 B]                     
Get:4 http://ppa.launchpad.net precise Release.gpg [316 B]
.
.
.
[email protected]:~$ sudo apt-get install codeblocks
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  codeblocks-common codeblocks-dev codeblocks-headers libcodeblocks0
  libwxsmithlib0 libwxsmithlib0-dev wxsmith-dev wxsmith-headers
Suggested packages:
  libwxgtk2.8-dev wx-common codeblocks-contrib
.
.
.
--------------------------------------------------------------------------------------------------------------------------------------------------------