Author Topic: Turn off a feature  (Read 8483 times)

Offline block_head

  • Single posting newcomer
  • *
  • Posts: 4
Turn off a feature
« on: July 04, 2013, 09:21:48 am »
Thank you for taking the time to read this.
I only recently picked up programming as a hobby. Code Blocks is great to work in, but I want to turn off a feature and dont know how. The options I can find are all gibberish to me.

Say I am typing scanf("%i",&number);, by the time I get to the first '(' there is this annoying pop-up, like a mouse-over text that says "_CRTIMP int_cdecl_MINGW_NOTHROW" which covers whatever I am typing until I get to the ';'.

I'm sure this is a helpful feature for people who know what this means, but can I turn this off? Been living with this for a while, but finally decided to see if something can be done.

Thank you.

EDIT: TYPO
« Last Edit: July 04, 2013, 09:25:50 am by block_head »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #1 on: July 04, 2013, 01:16:19 pm »
What version of C::B are you using? I think I've fixed this problem long ago.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline block_head

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off a feature
« Reply #2 on: July 04, 2013, 01:44:29 pm »
Sorry, should have mentioned that. It's CB 12.11.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #3 on: July 04, 2013, 02:08:44 pm »
Can you post a screenshot? Use a pastebin like service for images, because forum space is a bit limited.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Turn off a feature
« Reply #4 on: July 04, 2013, 02:29:52 pm »
I think the misfeature that you're talking about is "SmartSense". This can be turned off under Settings --> Editor --> Code Completion.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline block_head

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off a feature
« Reply #5 on: July 04, 2013, 02:38:04 pm »
 :) oBFusCATed I thank you for taking the time to look at my problem. What Thomas has suggested has solved my problem.
Settings>Editor>Disable Code Completion
has done it for me.
Appreciate the help.
God Bless :)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #6 on: July 04, 2013, 02:39:54 pm »
Can you post the screenshot with the option enabled?

(the option is "Display info when hovering blabla")
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline block_head

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off a feature
« Reply #7 on: July 04, 2013, 06:03:39 pm »
I went out after my last post, so took a while to post this.
Here is a screenshot, problem is, it no longer covers my cursor. Go figure! :D
But that "mouseover text" would appear over my cursor, so I either had to hit the up or down arrow keys to go down or up, to lose the text and type in peace again. For some reason it appears lower now. I understand why you would want to see this, so here it is.

http://tinypic.com/view.php?pic=21mcd1z&s=5

EDIT: TYPO
« Last Edit: July 04, 2013, 06:06:31 pm by block_head »

Offline zetab

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Turn off a feature
« Reply #8 on: July 05, 2013, 04:41:58 am »
When typing near the bottom of editor window, the pop-up window will block the typing.



If I narrow down the window width, the situation will become worse.




Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #9 on: July 05, 2013, 08:57:42 am »
Where is your cursor located? On the printf line?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline zetab

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Turn off a feature
« Reply #10 on: July 05, 2013, 02:03:37 pm »
Where is your cursor located? On the printf line?

No, it's on the memcpy line.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #11 on: July 05, 2013, 02:33:10 pm »
Works perfectly here on linux, can you try the latest nightly to see if it is fixed?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline zetab

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Turn off a feature
« Reply #12 on: July 05, 2013, 06:35:21 pm »
Just tried on nightly rev9158, yes, it's already fixed.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11770
    • Travis build status
Re: Turn off a feature
« Reply #13 on: July 05, 2013, 06:49:22 pm »
OK then, seems I've fixed it after 12.11 :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline sansoo

  • Single posting newcomer
  • *
  • Posts: 2
Re: Turn off a feature
« Reply #14 on: August 09, 2013, 03:48:18 am »
I am getting this same problem in 12.11, on vista. every time I turn off smartsense it turns back on by itself...

if I turn off code completion this goes away but I don't really want to do that

http://picpaste.com/cb-U12IrZrX.jpg
« Last Edit: August 09, 2013, 04:00:39 am by sansoo »