Author Topic: Xubuntu 12.04 and Code::Blocks 12.11  (Read 6614 times)

Offline LordJonas

  • Single posting newcomer
  • *
  • Posts: 4
Xubuntu 12.04 and Code::Blocks 12.11
« on: May 10, 2013, 02:59:15 pm »
Hi.

I'm trying to install Code::Blocks in my old laptop. Since the cpu does not apear to have pae feature enabled i was forced to use a kernel without it. So i decided to install Xubuntu 12.04 and give it a try. So far, so good. The main problem it's the version of code::blocks it was is 10.05.

Following some post here i decide to download the  release marqued as "codeblocks_12.11-2_i386-debian-stable.tar.bz2 (squeeze)".

Everything went fine until codeblocks-contrib complains about unmet dependy: "codeblocks-contribs depends on libhunspell-1.2.0 (>= 1.2.11); however Package libhunspell-1.2.0 is not installed"

I Just check all my packages and i confirmed that i've installed libhunspell-1.3.2-4...

So i ask: "what is going on here? Is there something i've missed?"

TIA

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #1 on: May 10, 2013, 03:35:23 pm »
So i ask: "what is going on here? Is there something i've missed?"
Yes, you made the worst mistake by installing 32bit linux, no one cares for them anymore.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline LordJonas

  • Single posting newcomer
  • *
  • Posts: 4
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #2 on: May 10, 2013, 03:36:49 pm »
You're joking, right?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #3 on: May 10, 2013, 05:01:51 pm »
Yes and no ;D
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline LordJonas

  • Single posting newcomer
  • *
  • Posts: 4
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #4 on: May 10, 2013, 05:07:53 pm »
So... can you be more precise??

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #5 on: May 10, 2013, 07:01:05 pm »
Is the issue just that you have hunspell 1.3 when the dependency is 1.2 (>=1.2.11 still means 1.2 ??). Try changing the dependency version in the deb/configure/make files.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #6 on: May 10, 2013, 09:46:20 pm »
Try changing the dependency version in the deb/configure/make files.
Don't do that.
You will most likely fail misearbly due to incompatible libs.

Just read the wole download-page especially the note for ubuntu users:
Quote from: http://www.codeblocks.org/downloads/26
Important note for Ubuntu users: The contrib-plugins package for debian can not be used on Ubuntu 12.04 and 12.10, due to an incomaptible libhunspell-package. Alternatively you can use the Ubuntu repo provided by our user pasgui

Direct link to the 12.04 (precise) codeblocks-files in pasgui's repo:
https://launchpad.net/~pasgui/+archive/ppa/+sourcepub/2829900/+listing-archive-extra

Offline LordJonas

  • Single posting newcomer
  • *
  • Posts: 4
Re: Xubuntu 12.04 and Code::Blocks 12.11
« Reply #7 on: May 10, 2013, 10:20:38 pm »
Hi Jen...

Thanks for the solution... it worked like a charm...

 ;D